Huion H950P pen pressure isn't working

hello, so earlier this morning I wanted to draw, and I pulled out my drawing tablet and plugged it in. It lit up and my cursor was moving, but it was unusually fast and sensitive. I figured it was just me, but when i opened my drawing program it had no pen pressure, and was behaving as if my tablet was being mistaken as my mouse.


I updated my drivers as it told me and it became less sensitive, but my pen pressure still doesn't work. I've tried new / different programs and still, no dice. I even tried testing the pressure in the drivers "adjust pressure sensitivity" tab, but still nothing. I can't find anything about this online either,

I've tried replacing my pens nib and nothing,


I use a Huion Inspiroy(?) H950P 


please let me know if you can help!


My programs are paint tool sai, firealpaca, and medibang. I've tried adobe too, and still nothing

I know it's not a problem with the programs, but Im just trying to provide information

I've had this tablet for a year and haven't run into any problems until today.


Thanks!

  • Hi yo otisboots, may I know which driver version are you currently using? Please try uninstalling the driver, restarting your computer, and reinstalling the driver. When you install the driver, please make sure that your tablet is not connected to your computer, your antivirus is turned off and all your drawing programs are closed. You can download the latest driver for your tablet from this link: Huion H950P Graphic Tablet Drivers.


    Best Regards,

    HUION Customer Support

Login to post a comment