HUION TABLET EXE not working

I've been having the most stressful two weeks of my life, my old PC crashed and I've had to get a new PC, and now after downloading and installing the latest driver for my Huion Kamvas Pro 22, the app is unable to run, it just says:

The application was unable to start correctly (0xc000007b).

I'm so confused, does anyone have any idea how to fix this? I need to get work done, I'm already over two weeks behind.


3 people have this problem
  • Hi Jay Wong, the error you encountered is commonly caused by trying to load a 64 bit DLL into a 32 bit process, or vice versa. This can be fixed by reinstalling the driver. Please follow the steps below:

    1. Uninstall the tablet driver you've currently installed and unplug your tablet from your computer. In your Control Panel, please check whether there are any other tablet drivers you've installed. Please properly uninstall if there are. It is important that you only have one tablet driver installed on your computer.
    2. Download the latest driver for your tablet from this link: Huion Kamvas Pro 22 Tablet Display Drivers. Then unzip the downloaded file.
    3. Before installing, please make sure that your tablet is not connected to your computer, your antivirus is turned off, and all your drawing programs are closed.
    4. Right click on the unzipped driver file and click "Run As Administrator" to install the driver.
    5. After the driver has been installed, connect your tablet back to your computer, open the driver, and check whether everything is all good.


    Best Regards,

    HUION Customer Support

  • i have been having this same problem.  I am currently using a HS611 and the latest driver has worked on my old laptop which runs on win 7 but the new desktop which is running win 10 is showing "The application was unable to start correctly (0xc000007b)."

  • Hi Imtiaz Al Hasnain, aside from reinstalling the driver based on the steps previously provided, if you still encounter the same error, please try the steps below:

    1. Restart your computer
    2. After restarting your computer, if the error remains, reinstall the driver again by following the previously given steps. IMPORTANT: Make sure your antivirus is turned off, your drawing programs are closed and your tablet is not connected to your computer when installing the tablet driver.
    3. Right-click on the driver icon and click "Run as Administrator".


    Best Regards,

    HUION Customer Support

  • I have a same problem, using H430P on Win 10 64bit showing "The application was unable to start correctly (0xc000007b) 


    Already follow previous how to (uninstalled etc) but still  showing the same error.

    Btw, is "Synaptic Pointing device driver" considered as tablet driver? since there're no tablet driver as Huion on the control panel. 


    Is there any driver for win 10 64bit ? 

  • I'm also experiencing the same issue. I have a Huion H950P, and I've been trying to install it on my Windows 10 64bit laptop. It did install, but when I open it, it says 


    "
    huiontablet.exe - application error the application was unable to start correctly (0xc000007b), click ok to close the application.
    "


    I have tried every solution on the internet (install DirectX, enable .Net frameworks, etc.), but none of them worked. It'd be gladly appreciated if anyone could help me. 

    Also, I don't see an option to choose between 32 bit and 64 bit on the download page. 

  • Oh, and I forgot to mention that it was working perfectly fine before. I formatted my laptop due to some circumstances and had to reinstall the drivers. The first time I installed was around March-April. The next time I had to reinstall was in June. And I noticed that they had updated the drivers (Date of Release 2021-05-30 Driver_15.3.19.174) so I think it's a bug in the new update. Also, while going through the program folder, I find two folders, "x64" and "x86", with both having the same content, 2 folders named "x64" and "x86", and a file named wintab32.dll. Inside of each of those 4 folders, there's a file named "wintab32.dll". Isn't it supposed to be "wintab64.dll" since I have a 64bit windows? And why do the "x86" folders exist inside the "x64" folder?

  • Hi, I've got the problem resolved and the application is launching correctly. It seems that the problem is with the .Net frameworks. Yesterday, I was reinstalling node.js for some purposes and when installing chocolatey, I guess it fixed the .Net frameworks. Though I do not know how to exactly fix the problem without installing it, I guess this is the only solution we have right now. DirectX does not work and doesn't fix the .Net frameworks at all. Also, most websites where you can download DirectX are sketchy and can contain viruses or malware. So, I guess what you can do if you really want to fix the problem is to try installing chocolatey which will fix the .Net frameworks as it installs, and then uninstall it after the problem's fixed. But I wouldn't really call this a "solution" to the problem, it's just one way to get around it. The problem isn't with the Huion application, so the devs can do nothing about it. 


    PS: I'm not a Huion staff, I'm just a programmer who wants to play Osu with my tablet. 


    1 person likes this
  • You're a life-saver!


    1 person likes this
  • Glad it helped! ^w^

  • Since you bought a new pc huion drivers requires 64bit 86bit something like that XD I was advised to install Runtime redist from the official microsoft site.. I installed both 64bit and 86 bit and reinstalled huion driver after. Then it worked! I hope it worked for youtoo


  • I have come up with a solution.....it's just missing redist...you guys can download it from microsoft official website....I am also giving you download links for it just install it according to your system...https://drive.google.com/file/d/11YxRVOxtCg9YldOCOXm-0_JroIBtOuEr/view?usp=sharing

    Don't worry it's not a virus. You can scan it if you want

Login to post a comment