Start a new topic
Solved

Pen pressure doesn't work - Windows 10

Hi! 


I'm using a Huion tablet model WH4109,

I installed the latest drivers and everything's working fine, the pen too, BUT, the pen pressure doesn't work at all and i can't even acces to the pen pressure test on the Pen Display, i've tried to install and reinstall everything 7 times but still doesn't work :/


A little help would be appreciated!

1 Comment

Hi Alicia,


Thank you for reporting your concern. Does your tablet driver show "Device connected"? If it shows disconnected, your tablet was not able to successfully connect to your computer either due to the wrong driver installed or some other reasons. Thus, please uninstall and reinstall the tablet driver. Make sure that the tablet is not connected to the computer when you reinstall the driver. You can download the latest driver for your tablet through this link: WH1409 Drivers


If you don't  know which driver to install, please contact us through service@huiontablet.com for further assistance, and provide the following:

  • Purchase order number
  • Product serial number (found at the back of the tablet)
  • Link where you purchased the tablet
  • A video showing your issue. You can use your phone in taking the video and make sure you capture the tablet, its connections and the monitor. You can send the video through WeTransfer or upload it to Google Drive and grant permission to anyone with the link to view it.

Looking forward to your reply or email. Have a great day!


Best Regards,

HUION Customer Support

Login to post a comment