Kamvas 13 Keeps Disconnecting and Reconnecting

Hey there! Recently bought the Kamvas 13 from Amazon and immediately fell in love with it but recently its been having issues staying connected. I'm using the 3-1 cable and it will start a cycle of disconnecting and reconnecting. The screen will stay on but the led light will be constantly turning off then on with the windows noise signaling a device being disconnected. I've tried updating the driver (none available), reinstalling the driver, unplugging the tablet and plugging it back in but it always ends up doing this. Is this a driver issue? Cable issue? Bad tablet?

25 people have this problem
  • I just noticed... Did Huion just STOPPED REPLYING TO THIS THREAD? Two months and not a single reply... Wow.

    1 person likes this
  • I mean if someone has started legal procedures about that specific problem, if there's any way the people could contribute, including me, I think we would be more than happy to do so. We'll help in any way we can.


    Quick update on my tablet, haven't had any disconnects since I found the solution. Please note that my problem was the constant loss of function of the pen and buttons, every thirty seconds to two minutes or so, and I had to unplug/replug the tablet multiple times for it to work again for another 30secs / 2 mins. Apart from that, Pen pressure (when the pen was active) and screen worked fine.

  • That is nothing that the issue we have. The tablet physically is disconnecting and reconnecting. It happens kind of randomly, although some of us can trigger the problem manually with external devices. (I could trigger it while turning on or Off my Xbox controller) It can do it multiple times in a row. Losing function in the buttons or pen is another known problem that is 100% related to drivers.
  • Nothing like the issue you have. I had the exact same problem as the OP. I agree with you that it does look more like hardware failure on your side though.

  • I have the same random disconnection/reconnection problem with both tablets, even the new one I managed to get after opening a ticket, the problem on several of the 3 test PCs and yet the last solution fixed the problem for me...


    1 person likes this
Login to post a comment