Kamvas 13 Keeps Disconnecting and Reconnecting

Hey there! Recently bought the Kamvas 13 from Amazon and immediately fell in love with it but recently its been having issues staying connected. I'm using the 3-1 cable and it will start a cycle of disconnecting and reconnecting. The screen will stay on but the led light will be constantly turning off then on with the windows noise signaling a device being disconnected. I've tried updating the driver (none available), reinstalling the driver, unplugging the tablet and plugging it back in but it always ends up doing this. Is this a driver issue? Cable issue? Bad tablet?

26 people have this problem
  • Jon. I've got a replacement unit. It doesn't happen to it. Same drivers.

    If i plug the old one, it happens. Nothing to do with what you say.

  • Hold the congratulatory new tablet for Jon Kaylor 'cause 


    I didn't bother taking the first tablet out of the box, but I have the replacement connected and it already bipped twice since I use your method. I have no idea what triggered it since I wasn't doing nothing much, just buying a bus ticket online. It's totally random with the replacement as far as I know.


    I will try any idea you guys have, so keep shooting.


    About the support, did they already solved the server thingy and are back to the original mail adress? 'cause I sended an e-mail 13 days ago and no one answered. I didn't say much because I can't reproduce the error to actually catch it on video but I don't know what to do now ( the device is connected to the power outlet and all that stuff) and would also like to know how to register the replacement for warranty since it is a new unit.


    Anyway, I will be away for a couple of weeks and won't be able to test any ideas till I get back to my desktop. But I will keep an eye on the forum.






  • Tried Jon's solution but the problem still persists, I haven't submit a ticket yet, but maybe it's time to do it and wait for a response.

  • Useless company, doesn't even bother to file a correct solution, as always it's just all money. I don't want a new fucking tablet, i have no money to spend on stupid customs. Now when the tablet disconnects and connects my pc freezes during that period. The worst fucking company possible to buy a tablet. If you are reading this, do yourself a favor and throw your Huion tablet in the trash, and switch to a competent company that CARES for their customers.

  •  I am currently working on a Youtube video describing my experience with Huion and their terrible customer support. If anyone on this thread would like for me to share their experience as well please let me know, I would be happy to share them. I feel it is important to let people know before they buy a tablet from Huion, and specifically this tablet model that has yet to be recalled or even addressed.


    4 people like this
  • Customer service has told me that they will send the replacement device and that I will receive the tracking number

    Now it's been 5 days and I haven't received the tracking number and customer service hasn't even responded


  • @ehab, I've found that Huion support doesn't work on weekends, so things filed on Thurs/Fri can run into Tues/Weds pretty easily.  On the other hand, Fedex does move a lot on weekends. In my case, iirc, I received my replacement before being notified that it was on the way.

  • David Horita

    So why don't they answer?

  • Ehab,


    I think they're just really bad at/unprepared for global returns on the scale of the Kamvas 13.  


    In the US they have local distribution and stock turns over fast enough that the defective SNs aren't still in the supply chain.  Given that they've sent some people bad second tablets (at least from the discussion here), they didn't recall bad models but just left in them in distributors' warehouses.  

    Even here, returns isn't coordinated with replacement.  I had to send the tracking number of my return shipment to tech support (twice, once with the link to the post web site) so they could verify the returned product (presumably because the returns department couldn't).  Actually, the return address was a house in NY (google street view), so not even a warehouse-type thing.


    But at least in my case the whole return/replacement was handled in-country, so no VATs, import/export taxes, or holdups in customs.  Huion is selling a lot direct to consumer but doesn't have the ability/knowledge/willingness to support returns, especially on a global scale.

  • Seeing that this thread is 26 pages long, and there's still no solution for this problem, I come here with no hope of a helpful answer.


    I bought a Kamvas 13 last November, and starterd to have this disconnecting and reconnecting issue in the very first day. At the time, after a long research, I killed the Huion process in the task manager and blocked it from the startup. This seems to fiz the issue. But clearly it is not an acceptable solution. Everything still worked fine, but every time that I had to adjust something in the Huion software, the issue came back.


    After all this months, I came here hoping that maybe Huion solved the problem, but nope, even with all theses unhappy customers with faulty produtcs, still nothing. So, it's correct to assume that Huion manufactured a bad product, didn't test it enough, and sold them to people without giving a single f***.


    Shame on you Huion for doing what you did. This was the first and last time that I bought a product from you. When it finally dies (as your products are know to do very quicly), I'll buy on from Wacom. Sure they are expensive, but their support pages don't have near as much of unhappy customers as yours.


    And you if you are a artist looking for a display tablet and happend to stumble here, trust me: a Huion product is just gonna give headaches. No matter how many youtubers you saw using Huion products, they all were paid to do so.


    Sometimes we just need to accept that cheaper = bad.

     

     

     

     

     

     

     

     

  • i got the same problem with my huion kamvas pro 20, after updating the driver, it will constantly disconnect and reconnect, however if i revert back to the old driver. it completely works. have you tried reinstalling an old driver? i have a feeling huions newer drivers are completely bugged.

    i hope this kinda helps

  • I have a kamvas 13 that I have tried to make work for a year and it kept disconnecting. At that point, I was just saving up some money to throw that one in the trash and switch brands. It's not like I could manage to sell a 400$ tablet that didn't work anyway.


    I have tried all of the fixed presented on this forum multiple times and pleaded with support for some help to no avail but I have found something that appears to have fixed the problem.

    I don't know if it's a combination of multiple fixes that have worked together to make it work but PLEASE DISABLE WINDOWS INK.


    I tried that before, and that didn't work, so I have no idea why it works now. Here are the information about my setup so you can replicate it to the best of your abilities:


    - Kamvas 13 CS1331 vM19f_200904

    - Driver v15.3.19.174

    - Windows v190420.1237

    - Installed Huion Firmware Fix

    - Applied aver aver's fix, visible on page 15 of this article

    - Disabled Windows Ink


    Back when I was using the v4 drivers, I remember having tried disabling Windows Ink and didn't do anything, so it must be something else in my fix that also contributed to it working.

     

    I'd be interested in knowing if it works for anyone else. Like I said, I struggled with this for a year, so I'd be happy to know if my solution to this very frustrating puzzle can help anyone else as well.


    I'd like to thank the lack of support from Huion, because if they hadn't insisted on letting my on my own devices multiple times, I probably wouldn't have a working tablet by now. 


    Thanks!


  • Francis Préseault


    Thanks for trying, but that simply didn't do anything.

  • >Francis Préseault


    This time the solution seems to work for me, after testing for a week, no more disconnection and loss of pressure except for a few times when the PC come out of the hybernation...the first time I tried the aver solution, it didn't work, maybe this time disabling windows Ink made the trick.


    1 person likes this
  • Windows ink is 90% of the functionality of every tablet, unless it is for debugging, it makes no sense to disable it. (It also doesn't help on the tablet that has the issue)



    THIS IS HARDWARE FAILURE. Why is it so hard for you to admit?


    You need a class action lawsuit. It's been months since I've got the replacement unit and It has no issues at all, although I had to pay double for it on everything. It is straight up impossible that all 350 people posting here have the exact same issue with totally different causes. "oh! You have firmware issues, Oh, you have pro les with driver, Oh, you have to check your cable! Oh and that particular one you that seems to be potentially capable to sue us, you get the replacement device that magically has no issues at all, BUT YOU HAVE TO PROVE you have the issue with as many evidences as you can, INCLUDING the ones we request for a device we know had a massive internationally known issue.



Login or Signup to post a comment