Start a new topic

my tablet and pen isnt working (H420)(battery_powered pen)

I have the H420 tablet and pen for over 2 months now. But today the pen won't move the mouse cursor even though the tablet is connected.

I switched the pen battery and replaced the nib. It still the same. I also checked the tablet and nothing is broken. I don't know what to do at this point, can you help me?

2 people have this problem

I have just bought a WH4109, installed and uninstalled the driver 8 times and my rechargeable pen (I think) does not work. I have been through the FAQs, charged the pen overnight, tried it left plugged in, changed the nib and given myself an uppercut. I've tried it with and without the driver, on another computer (surface pro), inside, outside and upside down.

The little pen indicator doesn't light up and I get a message that the wireless dongle has malfunctioned because Windows doesn't recognise it. Can you help please as it is a very expensive serving platter at the moment.

Hi Debbie Seazell, I'm glad that your tablet is working fine now. Enjoy!

Best Regards,

Huion Customer Support

Thank you, don’t know what happened before but I am operational now! 

Hi Noemzo R and Debbie Seazell, thank you for your responses. Please try the steps below so we will know what the root cause is:

  1. Check if the tablet driver is installed on your computer. From the OS X Finder, hit Command+Shift+A to jump to the Applications folder. Search for the "HuionDriver" application. If you find it, that means you have installed the tablet driver. If you don't, it means that you have not installed it.
  2. If you found the HuionDriver app in your Applications folder, expand it  and double-click "TabletDriverUninstall" to uninstall the driver.
  3. Unplug your tablet from you computer and reboot it after the driver has been uninstalled.
  4. After rebooting, plug the tablet back in and check if the tablet works without the driver. Check if the tablet's light turn on when you touch the pen on the tablet's surface and when you press the tablet's shortcut keys. If it turns on, that means that the tablet is working. 
  5. Unplug the tablet from the computer again and make sure there are no other tablet drivers installed on your computer, whether from us or from other brands. 
  6. Turn off your antivirus and while the tablet is not connected to the computer, reinstall the driver which you can download from this link: Huion H420(2048) Graphic Tablet Drivers for Mac OS. You can check out this article on how to properly install the tablet driver: How to Install Huion Driver on MacOS. Instead of adding "TabletDriverAgent" to your whitelist, add "TabletConsole" instead.
  7. Connect your tablet to your computer and check if the tablet driver shows "Device connected" and if the pen now has pen pressure.

Best Regards,

HUION Customer Support

found the e mail, I will send a video

my computer is macOS Catalina.  version 10.15.3


don't know




how do I do this? if you give me an e mail address ill send it


2. No idea
3. Mac OS X 11.10.6
4. No idea

5. Medibank Paint version 4.1.2

6. i'll email. it

Hi Noemzo R and  Debbie Seazell, we would appreciate it if you provide the following information so we will know how to proceed:

  1. Does your tablet driver show as "Device connected"?
  2. Does your tablet work without the tablet driver?
  3. What is your computer's operating system and its version?
  4. What driver version have you installed?
  5. What drawing software and version are you using?
  6. Kindly provide a video that clearly captures your issue.

Best Regards,

HUION Customer Support

I have a new h420 and it doesn't work at all. the driver is installed, I have changed the nib and battery but nothing?

I tried the same thing but when i tried to load it again, it still docent work...

Hi Olanrewaju Ebenezer Opaogun, due to the restrictions in shipping batteries, we do not include the AAA battery in the package. All the contents you've enumerated you found in the box are all that comes with it. Please refer to this link: Huion Official Store: H420 Graphic Tablet. As you can see at the bottom of that page, there are only 5 items included in the box which does not include the AAA battery. Kindly purchase the AAA battery separately. 

Moreover, you can download and install the driver for your tablet and the user manual using this link: Huion H420 Graphic Tablet Drivers. Please take note of these reminders:

  • Do not connect your tablet to your computer while you install the tablet driver. Otherwise, it will cause some issues with your tablet's performance. 
  • If you are using a Mac computer, make sure you add "HuionTablet" and "TabletConsole" to your whitelist. Go to Mac System Preferences > Security & Privacy > Privacy > Accessibility

Kindly check out this video on how to properly insert the battery to your pen and how to turn it on: How to use the battery pen (Pen 68)?

Best Regards,

HUION Customer Support

I bought huion h420 and no battery on the box and I can't unscrew the pen to insert a battery what can I do. But the one that I saw on youtube is with battery and software but this carton contains tablet, pen, usb cable, 4extra nib and manual which I attached the image.

Hi Kaylan A., I'm sorry for the late reply. 

If you have done the steps I've previously provided, kindly take a video of it and send it to We will then assess whether your pen is broken or not. These are the information we need:

  • Purchase order number
  • Product serial number (found at the back of your tablet)
  • Link where you placed your order
  • A video that clearly captures your issue. You can send it through WeTransfer or upload it to Dropbox or Google Drive. If it's the latter, make sure you remove the restriction so anyone who has the link would be able to view it.

Best Regards,

HUION Customer Support

I have the same problem with my h420. When I first got it (off of Amazon), it already had problems. If I were to power off my computer, the pen would not connect and I would need to uninstall and reinstall the driver for it to work again. Now, the pen doesn't work at all. I switched the battery and the nub, I rebooted my computer, I have never dropped it, and my computer says that the tablet is connected. It does not work without the driver either. I bought it off of Amazon one month ago so I am not sure if it is returnable. What should I do if this is the case?

Login to post a comment