kamvas 13 pen not working.

It shows device disconnected, and does not work on device diagnosis. I've tried restarting my computer, reinstalling the drivers, unplugging the tablet. Only the pen doesn't work.


1 person has this problem
  • Hi Will, I'm sorry about that. May I know if you have tried the steps in this article: What To Do When Huion Driver Shows Device Disconnected? If you haven't, kindly try them and see if your issue gets resolved. If it persists, please provide the following:

    1. The first 7 digits of your serial # (found on the back of your tablet, which starts with S/N)
    2. Your computer operating system and version
    3. Are you using a desktop or laptop?
    4. Are you using the 3-in-1 cable or the full-featured USB-C to USB-C cable?
    5. Which tablet driver version have you installed?
    6. Kindly provide a video or pictures of your cable connections from your tablet to your computer so we can check

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment