Solved

can't enable "Support TabletPC" option (H610PRO)

Hi, I have an H610PRO model - the old 2048 model, not the 8192 or the v2. Recently, the pen pressure stopped working with Autodesk Sketchbook (presumably because of Windows Ink) so I opened the driver menus to turn on "Support TabletPC" and see if that helped, but the checkbox is grayed out and can't be enabled. I'd update my drivers, but since the tablet is old it doesn't seem to be recognized by drivers newer than the 12.4 versions. Is there a workaround for this? It would be frustrating to have to switch to a whole new program or get a new tablet just because of this. I've never had any persistent problems with it until now.
  • Hi cal, I'm sorry to inform you that only version 12 drivers are compatible with your tablet. May I know if you tried reinstalling version 12.4.2? Do you have other software that you can draw or write on? If you do, kindly test if your pen has pressure on another software. 

    I believe you are using a Windows computer, so kindly provide your computer's Windows OS version and your Autodesk Sketchbook version.

    Best Regards,

    HUION Customer Support

  • Yes, I'm using the latest version of Windows 11, and my pen pressure does work in other programs. My Autodesk Sketchbook version is NOT the latest release, it's an old version from when it was free, but this problem only started a few days ago, shortly after I updated Windows. I've reinstalled 12.4.2 twice now and haven't gotten different results.
  • Hi cal, thank you for your reply. Since you have pen pressure in other programs, and the issue only started after a Windows update, the update may have caused your Autodesk Sketchbook to malfunction. Kindly try reinstalling the software. You can refer to this link: Autodesk Sketchbook (free version).

    Best Regards,

    HUION Customer Support

  • Hi Yesterday I started having the exact same problem. Windows updated a few days ago and I just noticed the pen pressure isn't working in any of my softwares. I does work when i test it in the same driver window but not any other software so I might believe is the windows update.


    I also checked and the "Support TabletPC" box is greyed out in the driver window and I can't activate it anymore. MY tablet is also a Huion H610, what can I do to fix this? I've tried plugging and unplugging, uninstalling and installing the driver, restarting my pc but nothing works.

  • Hi Sheila, may you kindly provide the following:

    1. Your Windows OS version
    2. The tablet driver version you are using
    3. The first 7 digits of your serial number (found on the back of your tablet, which starts with S/N)
    4. Your drawing software and version/s

    I look forward to your reply.

    Best Regards,

    HUION Customer Support

  • Yes this is my windows version

    Windows 11 Pro

    22H2

    22621.1555

    Windows Feature Experience Pack 1000.22640.1000.0


    My tablet driver is

    HUION_H610_H610Pro_1060Pro+_V12.3.7


    My S/N

    H610151


    About the software I am using, is Photoshop 2020 21.1.3 (I've worked using the pressure sensitivity here for years) , Illustrator 2022 26.3.1



    The thing is a believe my tablet isn't working with windows itself, I can still use it as a mouse, but no pressure sensitivity, I also had activated the option to use the pen to click and drag (as a mouse scroll) but now it isn't working either.

  • Hi Sheila, thank you for providing the requested information. Kindly uninstall your driver and install this version: HUION_driver_v12.4.3.230216. Please let me know if you still have any concerns.

    Best Regards,

    HUION Customer Support

  • Thank you so much!!! That fixed it!!! I've been struggling with this for like three days, I can finally breath! I've had this tablet for 7 years and it's still working perfectly so I really appreciate it!

  • Hi Sheila, thank you for the update, and I'm glad your issue is now resolved. Thank you for using our product throughout these years! Feel free to contact us here if you need our assistance. Or email us at service@huion.com. Have a productive day!

    Best Regards,

    HUION Customer Support