Solved

Huion KD100 Dial not working

I have the latest driver (Driver_15.6.4.103) for Mac OS and my computer is Mac mini with M2 pro chip, the system is Mac OS Ventura 13.2 (22D49)

I tried to set up the dial in the "Huion Tablet" app, and it is not responding. No matter what I assign the dial to, it still says "None" in the dial setting.

It is really frustrating not being able to use the dial. Someone please help, I believe I am not alone with this issue.

Thank you so much !!

  • Hi 何楽しい一日, we are sorry for your frustration in setting up your KD100. May I know if you have tried uninstalling and reinstalling the driver? Otherwise, try to install Driver_15.6.3.88 version. Here are some articles you can refer to:

    Are you using the cable or the wireless receiver? If you're using the wireless receiver, try using the cable, and vice versa. Please let me know if these steps do not resolve your issue.

    Best Regards,

    HUION Customer Support


    1 person likes this
  • Thank you so much. I installed the driver and used the old driver and it worked! Thank you so much for responding so quickly and professionally !!! SUPER HELPFUL


    :)

  • Hi 何楽しい一日, you're much welcome!

    Best Regards,

    HUION Customer Support