Kamvas 13 Device Disconnected and Pen not clicking

At first when I turned the device on, the pen would show my cursor, but wouldn't click when I touched the display. I looked up information about how to fix this and saw someone saying to uninstall and reinstall the device drivers. I did this, but when I reinstalled the drivers, it said device disconnected. this had happened 3 times in the past (each of which took hours to fix) however I don't remember what fixed it last time. So, are there any other ways to potentially get my device working again?

Things I've tried:

-Uninstalling and reinstalling the drivers

-Installing the Huion Firmware

-Using a different USB port

-Restarting my computer

-Updating graphics (gpu) drivers

-Updating windows

-Unplugging and plugging back in all related ports

-Using another computer

PS: Every time I try to use this device it feels like a new thing went wrong. At first it was a no signal error, then it was the display breaking, then it wouldn't turn on, then the drivers wouldn't work, then the device disconnected error happened for the first time, and then the pen didn't work, and then when I got that working it wouldn't click. Not only does this make me hate the product, and your brand, but it also sucks away my passion for art. As mentioned before, I usually spend hours trying to fix issues with this device only for it to break again next time I want to use it. At this point it feels like you're intentionally sabotaging your devices and trying to make people hate you.

  • Hi Greyson Trimarchi, I'm sorry to hear that you are experiencing problems with the tablet. Rest assured that we will sort it out. Kindly follow the steps below:

    1. Please close and exit from the Huion Tablet driver.  You can do this by right-clicking the Huion Tablet driver icon from the hidden icons in your screen's lower-right corner and clicking "Exit".

      image

    2. Install our TabletQC software, which you can download from this link: Huion TabletQC Tool.
    3. Check if the parameters on the left-hand side appear on the QC software. If you don't see the parameters, please unplug your tablet, plug it back in until the parameters appear, or reopen the QC software if needed.
    4. Draw on the QC software. You can choose to have pen pressure or use different colors as you draw from the "Menu" at the top using your mouse, or press the following keyboard shortcuts:
      a. F - enter or exit fullscreen mode (you'll have more accuracy when on fullscreen mode)
      b. B - change brush
      c. C - change color
      d. E - clear or erase
    5. Try pressing the pen buttons and the tablet's express keys (if your tablet has press keys). Test the dial, touch bar, or slider if your tablet has it, and check if the parameters change.
    6. Using a phone or other external camera devices, take a video as you perform all the steps mentioned above and send it to us (we recommend you upload the video to cloud storage such as OneDrive, iCloud, Dropbox, or Google Drive and share the link with us. Please don't forget to grant permission to anyone who has a link to view it). Please don't use screen recording; it is essential that we can clearly see both the tablet, the display, and your hand as you perform the test. Please refer to the screenshot below on what to observe and do in the TabletQC software.

      image


    Best Regards,

    HUION Customer Support


  • Hello, I'm not sure what you mean by "Check if the parameters on the left-hand side appear" here's a video of me getting up to that point. https://drive.google.com/file/d/1oRxhyo6ng87b-juXv57pd3IvUUv0SVk_/view?usp=sharing

    Before recording that, I did unplug and plug back in the device many times, along with closing and reopening the software, but nothing changed on the left.

  • Hi Greyson Trimarchi, thank you for the video. We have created a ticket and replied to you, please kindly check.

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment