Cursor keeps lagging + no pressure sensitivity

I keep having this problem where whenever I use my pen display the cursor will stop moving every few seconds and the pen pressure doesn't work. It seems to lag even when just on the desktop. If I turn of Windows Ink the cursor stops lagging, but I still don't have pen pressure. I've tried reinstalling drivers and trying older drivers.

The only place that the pen pressure seems to works is in the Pressure Sensitivity Adjustment settings and the Device Diagnosis, both with and without enabling Windows Ink.

Here's the specs:

Model: Kamvas 22 Plus

Driver Version: v15.6.3.132 (I've also tried using v15.6.2.80)

OS: Windows 11 Version 22H2

I've also attached a video of me trying to draw in in Photoshop and the Pen Pressure settings.

https://youtu.be/-j_8usHKsPw 

  • Hi Toastility, thank you for contacting us. We have created a ticket and replied to you, please kindly check.

    Best Regards,

    HUION Customer Support

  •  has this problem been resolved? As I have the exact same problem with my kamvas 22 plus. The pen works as a cursor, but no pressure sensitivity at all which renders the device useless.

    Kind Regards

  • Hi Angelique Duvenhage, thank you for contacting us. May I clarify the following things with you:
    1. Does no pen pressure happen in all software or only a specific drawing software.
    2. What is the version of the driver you are using.

    3. Have you tried to uninstalled and reinstalled the driver.

    Best Regards,

    HUION Customer Support

  • Hi. The version I am using is: Driver_15.6.3.132, the release date being 2022-10-14 of this driver. The is no pen pressure whatsoever, in driver application or elsewhere. I am using Windows 11. I have emailed support in hopes of a solution.
  • Hi Angelique Duvenhage, thank you for your reply. We have replied to you via ticket, please kindly check.

    Best Regards,

    HUION Customer Support

  • Is there a solution for this isseu? I have the exact problem in photoshop. not in zbrush tho. already tried to reinstall drivers but no succes. 
    I own a Huion kamvas 24 pro 4k


    Thank you in advance!

  • My problem was the pen itself, after replacing it, everything worked again.
Login or Signup to post a comment