h320M tablet pen not working.

So we bought the tablet off Amazon and it arrived today. We followed the instructions on the huion website for downloading driver, whitelisting the app etc. It says device connected, however we have a few problems once it's plugged in. 1. The mouse doesn't work at all. The cursor flies off to the side of the screen and the mouse won't move it. 2. The pen doesn't work either. It doesn't do anything. We have tried all the trouble shooting on the website. Uninstalling driver and reinstalling it, changing USB slots, restarting the computer. No matter what we do, we can't get it to work. If we plug the tablet in without the driver, the pen still doesn't work. With both the mouse and the pen not working when the tablet is plugged in, we can't do anything. For reference, we are using a Mac with Monterey. Any help appreciated!
  • Also, just to add; we have also tried using a different USB cable which didn't work and we have tried a wireless mouse and a plug in mouse, both of them do the same thing.
  • Another edit: I just tried it on a windows laptop to see what happens and it's doing the exact same thing on there too? I'm so confused why this is happening.
  • Hi Sarah Gregory, I'm sorry to hear that you are experiencing problems with the tablet. May I know what version of the driver is. Please try NOT to install the driver, just connect the tablet to your laptop without the driver to see if the issue will happen again?

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment