Pen Only works on pressure test screen (Huion Kamvas GT-190)

OS: Windows 10
I am attempting to use my Huion Kamvas GT-190 and a previously unseen issue has popped up. 

When I try to use the pen, it doesn't respond. No mouse movement, no left click from the pen tip. Right click button works,  and mouse will follow while right click button is held.

The only window that will actually respond to the pen properly is the pen pressure test window in the display driver.  That seems to work somewhat okay, but the moment I click out of the window it goes right back to the abnormal behavior. 

Pen is charged. Tried restarting,, the uninstalling the driver and reinstalling a new driver from the website for the GT-190, (12.3.7), which was the newest one I could find there. Prior, was using something like 12.4.2, not sure of the exact number, but the issue remains the same. Tried recalibrating the display, to no effect.  

(Have a ticket open for this, but figured I would reach out and see if any community members have suggestions on how to fix it as well.)

Login or Signup to post a comment