My Huion won't work anymore

I got a brand new Huion WH1409(8192) after having used a Wacom Intuos Comic for a few years in my Ubuntu 20.04. There's no issue with that, since it was pretty much plug&play. The problem comes when taking into account I have three screens, so I wanted to do the same thing I had with my last graphics tablet and map it to one of them.

Since Huion doesn't seem to have a "program" to change its settings like Wacom does, I could only find one solution: using the command "xinput map-to-output (tablet ID) (screen name)". Now, not only it didn't work, but my Huion stopped working altogether, or at least that I can see since my cursor won't move with the pen anymore (no matter if I use it in wireless mode or wired). 

On the other hand, the tablet lights up and when I use the "xinput" command I can see both my tablet's pad and my pen:

(3)] ↳ TABLET Pen Tablet Pen id=10 [slave keyboard (3)]

∼ TABLET Pen Tablet Pad id=11 [floating slave]

I tried using the same mapping command just to check, and now I get an error I didn't get before:

xinput map-to-output "TABLET Pen Tablet Pen" "HDMI-0" X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 131 (XInputExtension) Minor opcode of failed request: 57 () Serial number of failed request: 33 Current serial number in output stream: 34

I tried googling it, but the only relevant conversation I can find is someone who quite literally didn't write the names right. I'm super lost.

  • Hi Dan, thank you for contacting us. I am sorry to inform that Model WH1409(8192) does not support Linux now, our other models can support Linux, you can refer to this article: Does Huion have a Tablet Driver that will support Linux? Hoping for your kind understanding in this matter.

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment