Huion new 1060PLUS stylus pen isn't working, Please help!

While I using it, the pen suddenly died out and at first I thought it was cause of the tablet, I reconnected it
Still no, So I figured the pen might've been out of charge, so I charged it, but when I hooked it up, there was no light coming from the 2 buttons on the pen that usually lights up during charging, I tried hooking it up to the pc while I used it, still no. I figured the driver may not have been working, so I updated the software for Huion because I knew there was an update, but when I finished it, it still didn't work, Now I'm not sure what else I could do at this point, I thought I've done everything. what do I do? 

  • Hi Marsh, I'm sorry to hear that you are experiencing problems with the pen. No worries, we will sort it out. Please kindly provide us with the following information:

    1. What is your computer operating system, Windows or Mac

    2. Product serial number (from the back of the unit)

    3. The version of driver

    We will send you the steps of QC test accordingly.

    Best Regards,

    HUION Customer Support

    1 person likes this
  • Hi Jessica Wen, thanks for responding!
    The information you wanted me to provide is as follows:

    1. Windows

    2. The Serial number is S/N:91T38SH03144

    3. And the version of the driver is, v14.8.166.1482

    Thank you so much again!
    Also Best Regards and stuff,

  • Hi Marsh, thank you for your reply. Please uninstall driver  v14.8.166.1482 and reinstall Driver_15.6.2.80 to check if it will work fine.

    If it still does not work properly, please kindly follow the steps below:

    1. Please close and exit from the Huion Tablet driver.  You can do this by right-clicking the Huion Tablet driver icon from the hidden icons in your screen's lower-right corner and clicking "Exit".


    2. Install our TabletQC software, which you can download from this link: Huion TabletQC Tool.
    3. Check if the parameters on the left-hand side appear on the QC software. If you don't see the parameters, please unplug your tablet, plug it back in until the parameters appear, or reopen the QC software if needed.
    4. Draw on the QC software. You can choose to have pen pressure or use different colors as you draw from the "Menu" at the top using your mouse, or press the following keyboard shortcuts:
      a. F - enter or exit fullscreen mode (you'll have more accuracy when on fullscreen mode)
      b. B - change brush
      c. C - change color
      d. E - clear or erase
    5. Try pressing the pen buttons and the tablet's express keys (if your tablet has press keys). Test the dial, touch bar, or slider if your tablet has it, and check if the parameters change.
    6. Using a phone or other external camera devices, take a video as you perform all the steps mentioned above and send it to us (we recommend you upload the video to cloud storage such as OneDrive, iCloud, Dropbox, or Google Drive and share the link with us. Please don't forget to grant permission to anyone who has a link to view it). Please don't use screen recording; it is essential that we can clearly see both the tablet, the display, and your hand as you perform the test. Please refer to the screenshot below on what to observe and do in the TabletQC software.


    1 person likes this
  • Hi Jessica wen, thank you for responding again!
    I have done what you have asked me to do with the driver, but unfortunately it did not work, Although I have to admit the new UI is very pretty Haha, sadly it did not fix the problem with the pen
    So Instead I had to resort to doing the TabletQC software test, I did what you had asked me to do and filmed it as best as I could,

    The google drive link for the video is:

    In summary everything in the tablet worked, The express keys worked just as intended and the hotkeys remained the same, except for the one's from the pen, Unfortunately the main problem was still the pen itself, The software nor the tablet was not able to detect the pen while hovering over it nor pressing, I tried hooking it up to my pc while I draw, thinking it might've been the charge, but sadly so the results still remained the same, as of writing this I'm still distraught as to why it happened, It was perfectly working just fine until it suddenly did not. I really hope we can reach a solution soon, and I very much appreciate the help you've been giving thus far!

    Thank you very much for everything you've done so far!
    Best Regards again,

  • Hi Marsh, thank you for your video. We have replied to you via email, please kindly check. 

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment