Kamvas 22 Plus does not work on a Mini Mac M1 with Mac OS Monterey

Hello. 

I recently bought a Mini Mac M1 and then a Kamvas 22 Plus tablet. It worked perfectly. 

however, today it started to show some problems: the pen acted like crazy selecting items and I thought it was a matter of upgrading driver. It didn't worked, so I thought it was a matter of trying to see if the MacOs needs an upgrade. I had Mojave and changed it to Monterey. 

After installing the driver I haven¡t been able to make it work. Screen shows as attached and nothing works. 


Any help? 


Thanks

Cristian D.


  • I am having the same problem, my pen is all wonky and my screen looks like yours. I have tried updating the drivers and everything and it still isn't fixed. Did they ever give you a solution?


    1 person likes this
  • hey... Unfortunately they didn't but I got help from my brother-in-law who's a great geek and he could figure out this solution: Try to connect everything to a USB2.0 multihub port like this one. That'll help

    jpg
  • Hi Sammy Tragger, I'm sorry to hear that you are experiencing problems with the tablet. We assume it is caused by the cable connection. May I know how you connect the tablet to your computer, do you use 3in1 cable or our USB C to USB C cable? It would be appreciated if you could take a video that can clearly show how you connect the tablet to your computer.(upload to Dropbox or Google drive would be preferred and please grant permission to anyone who has the link to view it). 

    Best Regards,

    HUION Customer Support

  • Jessica, Where were you when I needed Guion Support? It was painful to find the solution by myself. Thanks.

  • Hi Cristian.doco, Please accept our full apologies for the inconvenience caused to you. I am always here to help you out. Feel free to contact us again through service@huion.com whenever you need our assistance.

    Best Regards,

    HUION Customer Support

  • Hello. thanks. I will. No need to apologize, but I would have welcomed some help when I had the problem. Luckily a family member helped me and the tablet works fine. 


    an update of the software that runs the tablet that fits into the new M1 drivers on the newest Mac would be awesome. 


    regards


    CDC

Login or Signup to post a comment