Pen shortcuts get stuck?

I'm not sure how to exactly describe this- the buttons on my pen are set to eraser and eyedropper. If I press and hold, they'll temporarily switch to the tools, and when I release it, it comes back to the regular brush. The issue I have however, is that if I just press and release the buttons quickly, the tool will get stuck. Pressing the button again will not bring the regular brush back- I have to switch back to it manually. I'm not sure what is happening- I am quite certain I installed my drivers correctly, and the tablet is new. I have a Huion Kamvas 20 and use Clip Studio Paint.
Thank you in advance

1 person has this problem
  • Hi G C, have you tried a different shortcut and check if the issue persists? Kindly try a different drawing program as well or a different version of Clip Studio Paint and see if the issue is the same. Please try to reinstall your tablet driver and check if you encounter the same issue or better yet, install a different driver version. If the issue remains after trying these steps, let's test your pen further using our QC software. Kindly send an email to with the following information so we can assist you further:

    • Serial number (found at the back of your tablet, right after S/N)
    • Your purchase order number
    • Your computer operating system
    • Version of the Clip Studio Paint you are using
    • Version of the tablet driver you've installed

    Best Regards,

    HUION Customer Support

  •  Hello!
    Thank you so much for your answer. I may have found a solution after trying some things.
    Sadly, when I tried using different drawing software (Paint Tool Sai) it didn't really cooperate. Luckily I don't use it anymore, so I didn't really bother with fixing this part.. The drivers are new, and I have tried reinstalling them. None of these helped- however, I stumbled upon some thread that mentioned checking "preferences" in CSP. Changing the "length of keypress" to 1 ms seems to have gotten rid of this problem, though I'm not really sure how. Still, it seems that the problem is solved for me.
    Sorry if this thread was a bit redundant, but once again, thank you so much for your reply. Hopefully I won't run into any other issues, but even if I do, I feel confident that I can get help here :) Have a good day!

    1 person likes this
  • Hi G C, glad to know that. And yes, you also need to adjust the settings of your drawing software so your tablet can work properly in those software. Enjoy using our product!

    Best Regards,

    HUION Customer Support

  • Thank you G C! I was having the same issue and it was driving me crazy. 

    HUION Admin, consider adding this to support docs / FAQ?

    In appreciation,


Login or Signup to post a comment