Huion Kamvas Pro 20 (2019) USB problem or driver problem?

When I plug my device's USB in, I hear the "connect sound", but right after that I immediately hear the "disconnect sound". However it still seems to be connected according to the device manager. The pen still works, I just can't use the buttons and there is no pen pressure, because the driver nor the firmware recognizes the device. I get the "Device disconnected" message from the driver.

I tried using a different USB cable, and the same thing happens. I have tried reinstalling all the available versions of the drivers, including reinstalling firmware, and during installation I did not connect my device at all to my computer. I uninstalled the USB Composite Device from the Device Manager (but gets reinstalled when I reboot). None of it fixed it.

Yesterday I installed Scptoolkit as a driver for a game controller, but I have uninstalled it since I was thinking it was conflicting with Huion's driver. Is it possible that it has modified something in my computer that causes it to not recognize my display tablet? I don't know what that would be.

Been trying to fix this for the enitre day pls help.

  • Hi the h, since the tablet driver shows "Device disconnected", this is the reason why your tablet buttons won't work and you don't have any pen pressure. May you please check out this article and try the steps: What To Do When Huion Driver Shows Device Disconnected?. Was there an error message that popped up when you heard the disconnect sound? What driver version have you installed? Are you using Windows 10?


    Best Regards,

    HUION Customer Support

Login to post a comment