Device Disconnected Kamvas 16

Hi so I just bought the Kamvas 16 (2021) and I the driver seems to be having trouble connecting to the device. It did work for a brief moment so I know it’s but I haven’t been able to replicate it since. I’ve tried everything I could find; uninstalling and reinstalling, restarting the computer, checking the cables, running the program as administrator and pretty much anything I could think of or found others suggesting and done it at least twice. I’ve been trying this for hours now and finally decided to cave and come here. Help this is painful.
  • Hi Maiz, are you using the 3-in-1 cable or the USB-C to USB-C cable? Does your tablet's display work fine? Have you tried all the steps from this article: What To Do When Huion Driver Shows Device Disconnected? If you have and the issue remains the same, it is possible that your cable may be broken. Please send the following to service@huion.com to be further assisted:

    1. Serial number (found at the back of your tablet, right after S/N) 
    2. Order number
    3. Your computer operating system and version
    4. Version of the tablet driver currently installed on your computer
    5. Please state that you've already followed the instructions from the above-mentioned article
    6. Link to a video of your cable connection from your tablet to your computer and please capture what happens when you turn your tablet on as well. If possible, please demonstrate whether the pen can move the cursor or not on the video. You can send the video through WeTransfer or upload it to Dropbox or Google Drive and just share the link with us. Please remove the restrictions on the video as well so anyone can access it.


    Best Regards,

    HUION Customer

Login to post a comment