(PLEASE HELP) Kamvas 13 pen pressure not working

Greetings, I've had this huion for about a year or two and I've had pen pressure problems since I got the the thing. I got the pen pressure working for a good 6 months now I downloaded a new animation software to do my job and now the pen pressure doesn't work. I tried everything from replacing the nib, to reinstalling drivers and it still not working. Please help

  • Hi KarlCantSpell, kindly provide the following so we can check on it:

    1. Your computer operating system and version
    2. Name of the software you are having pen pressure problems with and the version
    3. The version of the tablet driver you installed currently
    4. The version of the tablet driver where the pen pressure worked
    5. A video of your drawing software and how you tried to set the pen pressure and try drawing on it as well so we can see.


    Best Regards,

    HUION Customer Support

  • Hello, I am having a similar problem. My tablet is a kamvas 12 and I´ve had it for some months and it doesn´t let me draw in certain programs. I started using a program and after some time it didn´t let me draw in it, the pen still worked in ther stuff. Then I changed to another program and it did let me draw. But again after some time it doesn´t let me. What can I do about it?  

  • Hi Aarón Castillo, when your pen stops working, does the tablet driver still detects your tablet being connected to your computer or does it show "Device disconnected"? Kindly provide the following as well:

    • Your computer operating system
    • Version of the tablet driver you've installed
    • Names of the programs you are using and their versions


    Best Regards,

    HUION Customer Support

  • ok so i am currently trying to use my kamvas 13 for the second time in its use and for some reason every time i draw a line, tap, select, etc., it reads as if i tapped twice. and if i draw two lines, and press the backspace, it erases both. i also realized while going on the pressure sensitivity settings for the pen that you can see that the lines are being drawn TWICE, overlapping one another. I just got this thing and im wondering if theres an easy fix or if my stylus is already broke

  • Hi Saralyn M., may you please provide the following so we can assist you better:

    • Your computer operating system and version
    • Version of the tablet driver you've installed
    • Drawing program and version you're using


    You can also try the following steps to either resolve or at least help troubleshoot your issue:

    1. If you have installed the driver, please reinstall it and check if this will resolve your issue. 
    2. Try connecting your tablet to another computer, if you have access to another unit, and check whether you have the same issue.
    3. Reinstall your drawing software or update it.
    4. Use a different drawing software and check if the issue remains the same.


    Best Regards,

    HUION Customer Support

  • Hello

    Answering ryour question, the tablet doesn´t show "device discconnected", and it still works, just not in the programs. And to th other things:

    -My opperating system is Windows.

    -The version of the driver is, at least the version number: v14.8.166.1482.

    -And the programms were: Paint Tool SAI, version 1.2.5, and the other one is Fire Alpaca, I can not find the version, but it says is the 64 bit one, so it may help.


    Thanks and best regards

  • Hi Aarón Castillo, thank you for providing your information. Kindly send the same information to service@huion.com so we can test your tablet using our QC software. This will help us check your hardware's performance.


    Best Regards,

    HUION Customer Support

Login to post a comment