Solved

Inspiroy Q11K v2: Keys not working

 I have a Huion Inspiroy Q11K v2 using the drivers v14.8.166.1482 on Windows 10 Enterprise. Some time ago the shortcut keys worked perfectly but at some point in time they stopped working. There is no response at all. In the configuration UI the option "Enable Press Keys" is activated and I tried it in user and admin mode. Also tried various possibilities, like different Key presses or build-in functions like switching the screen. None of the keys shows any response.

Drawing works without any problems however.

  •  Oh my :-(

    Found the lock switch on the top right side, which has been switched on unintentionally. Would be great if the UI could report the state of the lock switch and warn you.

  • Hi Carsten Schlipf, yes, the Q11K v2 has a switch on the side to lock the press key functions. I'm glad you found it.


    Thank you for your feedback. I'll forward this to the proper departments.


    Best Regards,

    HUION Customer Support

Login or Signup to post a comment