The tablet is not registering the pen

I have a MacBook Pro and the Huron kamvas 16 pro. Yesterday my tablet  was working fine, but this morning it is not registering some movements. I have restarted my computer and reinstalled the drivers, but nothing has worked. When I went to the calibration screen and tried to touch the target it only registers the occasional tap. I went to draw an image using ClipStudio Paint and I scribbled a line and only some parts appeared.I have tried on other programs and they all had the same results.


1 person has this problem
  • Hi KATO ART, please try the following steps to resolve your issue:

    1. Replace your pen nib with a new one
    2. Make sure there are no unnecessary electronic devices near your tablet. Electromagnetic signals emitted from other devices may cause issues with your tablet's performance.
    3. Uninstall your tablet driver, unplug your tablet from your computer, then plug it back in. Test whether your tablet works even without the driver. (NOTE: This step is not applicable if your MacBook Pro is running on Catalina or Big Sur)
    4. Try using your tablet on a different computer and check if you still experience the same issue.


    If you have dropped your pen, this could have caused the issue and caused damage to the pen. If this is the case, you may need to purchase a new pen using this link: Huion Battery-free Pen PW507.


    But if you have not dropped your pen and the steps given above do not resolve your issue, please send an email to service@huion.com with the following information so we can further test your pen using our software:

    • Serial number (found at the back of your tablet, right after S/N)
    • Order number
    • Your computer's operating system and version
    • Version of the driver you've installed


    Best Regards,

    HUION Customer Support

Login to post a comment