I've been trying all but my HS611 isn't detected

I think it might be an issue with my laptop since I've done about everything I thought to try to make it work, restarting it, uninstalling and installing the driver, or using older versions and it won't detect my tablet even if I run it as an administrator :(

1 person has this problem
  • Hi ShidoElBlitz, kindly try the steps found in this article: What To Do When Huion Driver Shows Device Disconnected?. Try using your tablet without the driver. Make sure your unplug and plug the cable back in after you've uninstalled it. Try using a different cable as well. If it still doesn't resolve your issue, please send the following information to service@huion.com:

    • Serial number (found at the back of the tablet)
    • Purchase order number
    • A video of your issue


    Best Regards,

    HUION Customer Support


    1 person likes this
  • Thank you for replying! I will do what you said and inform you if it works or not. But thanks a lot again :)
  • Hi ShidoElBlitz, you're welcome. We'll further assist you through the ticket if it won't get resolved even after following the steps on the article.


    Best Regards,

Login to post a comment