Urgent! Help! Works in Test, but NOT in Photoshop

Hi! I have the model 420, and I have been having the nastiest time with getting it to work continuously with my Mac. I have my mac updated, so that shouldn't be the issue. 

It was working fine for some time, then I stopped using the tablet for a month or so, and hen I plugged it in, the pen worked as it is supposed to in the Huion pressure test BUT NOT my editing/drawing app, Photoshop (I use CS4, and it has worked well with my tablet before) 

I have a project that I need to do today, any help is so appreciated.

Thank You!

  • Hi Elle Cuddy, I'm sorry to know about your tablet issue not working in Photoshop. Kindly try to check if you have added the necessary access to your driver by following the steps below:

    1. Open System Preferences > Security & Privacy > Privacy > Input Monitoring
    2. In Input Monitoring, please check if you have the "TabletDriver" app and see if it is checked.
    3. Still under Privacy, click "Accessibility", which is usually above Input Monitoring. Check if the "TabletDriver" app is also there and if it is also checked. 

    If the steps above do not resolve your issue, please send an email to service@huion.com with the following information:

    • Serial number (found at the back of your tablet)
    • Your MacOS version
    • The version of the tablet driver you installed
    • Your Photoshop version

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment