Huion Kamvas GT-191 V2

Hello, I've been using the Huion Kamvas GT-191 V2 for a little over a year now and I've never had any problems.

Today, all of sudden the tablet stopped working even though I was just using it a few hours earlier. The tablet connects with the screen of my computer and the tablet screen works as i can see what I'm doing on the pc, the problem is when i move the pen on the tablet screen the cursor doesn't pick it up and it doesn't move. It happened a couple of times that the cursor was able to pick up when i was using the pen but i only lasted for a few seconds and then i stopped working again. I also rechecked the driver panel and it says that the device is connected.

I've unplugged and replugged all the cables more than once, the computer I'm using is still the same one, my huion driver is up to date with the one from July (and I've already unistalled it and reinstalled it multiple times) and my pen is not the rechargable one so I don't really know what the problem could be.

If you could help me it'll be very much appreciated. Thank you for your time.

  • Hi Giulia Dalla Rosa, thank you for providing details of your issue and the steps you've done so far. It is possible that your issue is caused by the pen. Kindly try uninstalling the current driver you've installed, unplug your tablet from your computer, then plug it back in. Test if your tablet works even without the driver. If it does, then the issue is with the driver. But if it still doesn't, then it is possible that it is caused by the pen. 


    Since you already have a ticket, we will reply to your ticket with some steps to further test your tablet using our software. Please check your spam or trash folder if you don't see our reply in your inbox.


    Best Regards,

    HUION Customer Support

Login to post a comment