Pen pressure not working

Hello! My friend gave me a Huion H420 for gift, and I just tried it 5 months after they gave me because I waiting for my laptop to be back. I tried to install and follow the proper instructions I searched on internet (mostly yt). I hoped there was no problem, but when I want to open the "Pen pressure test" it wont open---I can't test if my pen already having a pressure. I tried it on Paint Tool SAI to see if it's still have pressure, but it didn't! I can't use my pen pressure! How to fix this? I don't want to dissapoint my friend, please help me!
mp4
  • Hi Rizu chi, thank you for providing a video. Since the tablet driver is showing as "Device is connected", it means that the driver recognized that your tablet is connected to your computer. 


    I've noticed that when you tried to open SAI, an error popped up as seen on the screenshot from your video below:


    This error is caused by a missing or corrupted dll file which caused issues in opening SAI. May you please try the following:

    1. Reinstall SAI
    2. Go to:
      • Control Panel > Programs & Features or Add/Remove Programs
      • Find Microsoft Visual C++ 2015 Redistributable (x64) or (x86) depending on which Windows version you are using 
      • Click Change > Repair > restart your computer
    3. Reinstall your tablet driver and make sure your tablet is not connected to your computer, your antivirus is turned off, and all your drawing programs are closed while installing the driver.


    Best Regards,

    HUION Customer Support

Login to post a comment