GT-156-HD-V2 issues

Having few issues with current pen display tablet. GT-156-HD-V2

Please note that I've installed / plugged the tablet into two other pc's at home and they all display the exact same problems listed below. 

1. Touch slide bar is ALWAYS activated.

It thinks it's being activated 100% of the time so whichever function that is bound to gets spammed. (ie. By default it's set to [ctrl +] for slide up and [ctrl -] for slide down, so computer gets mass input of Ctrl, +, - until I fully disable the slider bar keys)


Please note that I was not pressing or touching any keyboard / tablet buttons when I was recording this. 

That insane amount of key input happens 24/7 unless I fully disable the touch slider bar.

2. Stuttering issue when trying to use the tablet.

When the slider bar is fully disabled, I can somewhat use the tablet but with a huge frustrating lag / stutter issue while using the pen. See attached video link for better understanding of how bad it actually is. 

Even when it seems like it's not lagging, tablet is still registering a small sections of straight lines instead of continuous, smooth input.

Sometimes tablet works fine while drawing but often jitters and creates random straight lines from point A when it starts lagging and  then to point B when it stops lagging. 

Sometimes tablet stops taking inputs altogether making it unusable. 

//Things I've tried doing to resolve the issue

//tried my other drawing pen to see if it's the issue. (one was basically brand new as I never had a reason to use it since day 1) 

//tried ALL DRIVER VERSIONS listed on the website. from oldest to the latest. with each install, did uninstall>looked for any residual folders or files and delete> reboot > try again. 

//tried using the tablet on different pc's. two other pcs to be exact and both were clean, fresh install. 

//Purchased new 3 in 1 cable from huion website thinking it might have been the cable connection issue. RIP $80...

//Tried plugging in usb connectors to a different slot. 

//Giving huion-tablet service highest priority

//Running huion-tablet in admin-mode

Firmware version is HUION_M174_170925

If  anyone out there knows the fix for it... please let me know before I completely lose my mind...

  • Hi hj y, thank you for your videos and for providing the steps you've done so far. We will have to test your tablet using our QC software so we will further assist you through your ticket. 

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment