Problem with detecting pen on HS611

Hello, since a couple of days ago, my HS611 doesn't detect properly the pen on any device. To be able to move the mouse around, I need to press the bottom button but it also presses the primary mouse button at the same time so I can't navigate properly. And the top button is just random about detection. If you have any solution about that, thank you in advance !

  • Hi Maxim Cosmo, thank you for your reply. Whenever you see "Administrator privileges" on your tablet driver, please click on it to give your tablet driver the necessary access to your computer. 

    Since your tablet driver detected your tablet, then it may be possible that your issue is with your pen. Let's try to test your pen and your tablet further. I will create a ticket for you and send over the software.

    Best Regards,

    HUION Customer Support.

  • Hi, thanks for the quick response. I tried all steps you gave and none of them worked for me and it shows "Device connected" on the tablet driver.


    I was hoping for a software problem but yeah, don't seem like one. :l

  • Hi Maxim Cosmo, have you installed the tablet driver? If you did, does it show as "Device connected"? Kindly try the following steps:

    1. Uninstall the tablet driver, unplug your tablet and plug it back in. 
    2. Test your tablet without the driver and check if it works fine. 
    3. If your tablet works fine without the driver, then the issue is with your driver. Just unplug your tablet again, reboot your computer, turn off your antivirus, close all your drawing programs and uninstall the latest driver for your tablet which you can download from this link: Huion HS611 Graphic Tablet Drivers.
    4. On the other hand, if it still doesn't, then the issue may be caused by your pen, USB cable, USB port or the tablet itself. Please get back to us so we can create a ticket and we can further check on it.

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment