Q11k tablet pen not working

My tablet, which arrived a week and a half ago, has stopped receiving input from the pen. I tried all the fixes, uninstalled the driver, shut down my computer (macbook air) and still no good. I emailed for help a few days ago, but haven't gotten anything back yet. 

  • Hi Miles Gilberti, thank you for your post. We are currently experiencing a higher than normal ticket volume and we apologize for not being able to reply to your ticket right away. Rest assured we are working hard to accommodate all tickets the soonest possible. We appreciate your patience in this matter.

    As to your pen issue, please try to use the pen while connected to the charging cable and check if it works fine. Then try charging it for around 5 hours and test it without the charging cable after. If it works while connected to the charging cable but won't without it, then the Lithium-Ion battery inside the pen is damaged. Since you are still within the warranty, we will assist you in getting a replacement pen through your ticket. 

    Best Regards,

    HUION Customer Support.

  • Thanks a ton. I'll try charging for 5 hours, but it doesn't work with the cable attached. 

  • Hi Miles Gilberti, thank you for the update. Your ticket has been replied to and we will further assist you from there.

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment