Device Disconnected

Hi there

We brought a Huion GT220 V2 for my son for last Christmas and its 29th March and we have still not managed to get it set up correctly!

I have just brought a new computer as my previous laptop was very old and I thought that this might just be stopping me from setting up correctly - however, I still cannot get the Device Connected message and I just don't know what I am doing wrong???

Can anyone please help me!

With many thanks, Andria

2 people have this question
  • Hi Andria Geal, there are 2 versions of GT-220 v2; one with 2048 pen pressure and another with 8192. May I know the following information so I can assist you further: 

    1. The version of the tablet driver that you've installed
    2. Your computer's operating system
    3. Your tablet's serial number (found at the back)

    The reason why your tablet driver shows as "Device disconnected" is due to one of the following reasons:

    • The cable was not securely plugged in to the USB port
    • The USB port or the tablet's port is defective
    • The USB cable is defective
    • The wrong driver or an out-dated one was installed

    Thus, if you are experiencing this issue, please try the steps below and see if it gets resolved:

    • Make sure that the USB cable is connected securely, and the USB port is functional.
    • Use another USB cable and/or connect the USB cable to another port.
    • Change to another computer, if possible, to see if the issue still persists.
    • Re-install the latest driver from the Huion Official website using this link: Huion GT-220 v2 (2048 and 8192) Pen Display Drivers

    Best Regards,

    HUION Customer Support

  • I have a similar issue.

    I have the 8192 variant, and there for have been getting my drivers from said section.

    The tablet works fine on Driver_14.7.154.586  but as soon as I update to Driver_14.8.90 , the tablet is no longer detected.

    I have tried doing a clean uninstall/reinstall and swapping cables, but to no avail.

    I believe 14.8.90 is just bugged.

  • Hi Steven Jennings, kindly try these methods:

    1. When you see the "Administrator privileges" button at the lower part of the tablet driver, please click it and check if the driver works.

    2. If your don't see the the Administrator privileges" button, uninstall the tablet driver, go to C:\Windows\SysWOW64, delete the wintab32.dll file then reinstall the latest tablet driver. Note: Make sure your antivirus is turned off, all drawing programs are closed and your tablet is not connected to your computer when reinstalling the driver.
    3. If the first 2 steps above won't work, you can just continue using Driver version The difference between the two driver versions are minimal and are usually just about some debugging done for certain models.

    Best Regards,

    HUION Customer Support

    1 person likes this
  • I was able to solve the issue myself.

    1. Download Driver version
    2. In the settings (the small cog icon in the top right), go down to "Check for Updates". Allow this to run with internet access and it will notify the user that there is a new udate.
    3. Allow the update to be downloaded and run the update (note : this DOES NOT download the driver that is provided on the main website. Rather, it downloads driver_v14.8.73.993_beta)
    4. I received a continues stream of "could not complete due to overwrite issue". Solved this by deleting what was left of Huion Tablet in my C:\ drive and then re-ran the update.
    5. Finished update and everything works fine.

    Update the provided driver on the website. The newest driver provides hotkey profiles for the user which has been around for other providers for a long time. This update is extremely useful. Not just bug fixes.

  • Hi Steven Jennings, thank you for sharing the steps you did. I've referred this to our technical department and what you did was a valid method that can be used in case the more recent driver version doesn't work right away. 

    Best Regards,

    HUION Customer Support

  • I'm having the same problem with a h610 pro. I've tried installing on 3 separate laptops and two different usb cables. I download the driver but the tablet never seems to connect. Why won't it work?We've had this in a box for a few years now and have never been able to get it working no matter what we try.

    1 person likes this
  • Hi Lozza S, when you installed the driver, did it consistently show as "Device disconnected"? May I know what driver versions you've installed? Since you mentioned that you've had it a few years now, it is possible that you have the H610Pro with 2048 pen pressure. Kindly install the driver found in this link: Huion H610Pro (2048) Graphic Tablet Drivers. Please let me know the operating system you are using as well.

    Best Regards,

    HUION Customer Support.

  • Hi

    I have the same issue. I have a GT 156 HD V2 and using Catalina Mac OS. I downloaded the latest driver from the original website. Installing - uninstalling. Plug-in, plug off, switch on and off my computer and also changing the settings in Security in System preferences.

    The "device disconnected" keeps appearing. It´s weird cause the tablet is working as I can see it as a second screen and I can drag programs to the tablet, but I can´t use the pen :(

    Does anybody have any idea at this point?

    Thanks a lot in advance 

  • Hi elena menjon, are you using an adapter in connecting the 3-in-1 cable to your Mac computer? If you do, please try to change your adapter and try using a different port. If the tablet is displaying the screen, then the HDMI end of the 3-in-1 cable is working fine. The issue lies on the USB end of the 3-in-1 cable or the USB-C end that is connected to your tablet. Please try connecting it to a different USB port as well.

    If you have an access to a different computer, please try it with a different one and check if the issue persists. Do you have access to a Windows computer? Please let me know if you do, so I can send a software that can test your tablet's performance. 

    After all the applicable tests are done and if the issue is still the same, it is possible that the issue is caused by your 3-in-1 cable since it kept on showing "Device disconnected".

    Best Regards,

    HUION Customer Support

  • my h1161 disconnected i tried reinstalling the driver like5 times that didnt work. how do i reconnect it

  • Hi Aaron Harris, kindly try the steps found in this article: What To Do When Huion Driver Shows Device Disconnected?. Since you've already done Method #1, you can skip to Methods #2 & 3. Kindly answer the following questions as well:

    1. Does the tablet light turn on when you touch the pen on the tablet surface?
    2. Does the tablet light turn on when you press the tablet's buttons?
    3. What operating system are you using?

    Best Regards,

    HUION Customer Support

  • My Mac book air  is operating on Mojave. The pen was working fine (GT-191; 8192)last week, today nothing. device disconnected.

    I have taken off and reinstalled the drivers. Installed older drivers and tried to update - but the 'device is disconnected' keeps showing).

    I tried it on my daughters PC, downloaded the PC driver, which was a lot more thorough as a process. Everything connected and the pen worked fine on her pC. 

    Its not the hardware or  wires, its my computer and the drivers have somehow become incompatible. I read somewhere that maybe my computer can turn it into sleep mode, but I have turned this off and it hasn't worked.

    Any Ideas?


  • Hi Arrigoni, Francesca, you are right; since your tablet works fine on your daughter's PC but not in your MacBook Air, the issue is with the software. Since your MacBook Air is running on Mojave, kindly install Driver_14.3.11.190506 or Driver_14.3.10 version. When uninstalling your tablet driver, please make sure you don't just drag it to your trash. Instead, properly uninstall it using the Uninstall button in the driver or the uninstall application. You can check out this video on how to properly install and uninstall the driver: How to Install/Uninstall Huion V14 Driver on Mac OS (Video) and these articles as well: How to Uninstall the HUION MAC Driver V13 or V14 Properly and How to Install Huion Driver on MacOS.

    Remember, do not connect your tablet to your computer, turn off your antivirus and close all your drawing programs while installing the driver.

    Best Regards,

    HUION Customer Support

  • Hi, 

    I had a DEVICE NOT CONNECTED problem with my KAMVAS 16 Pro. I searched through he Huion support and also viewed some Youtube videos. Then I followed the suggestion that I should uninstall the driver and reinstall it having other tablet drivers and all anti virus apps off. I deinstalled my Wacom drivers and turned off my Malwarebytes program.

    I did those things and still had the problem and serendipitously, I saw a comment saying that after installing a driver, I should reboot. I did this and now my device is working.  Fingers crossed!!!

    Once rebooting was necessary for the complete install of most programs but no longer. I feel that Huion is not serving its customers by not giving good step by step instructions for set up and other tasks. It seems the instructions were drafted by folks who are using the product everyday, for a long time and probably were involved in development. What is needed is a technical writer whose  training and experience are in creating guides for the person with no experience with computers at all so each step is detailed. Anyone who in writing a guide looks at a step and assumes, "Don't have to put that  in. Everybody knows that."  is doing the customer and company a disservice. One of the major drivers of return business is the ease of getting the product up and running!!!!!

Login or Signup to post a comment