can't draw with pen (h430p)

I bought this a month ago and just tried it out.

My computer can sense the pen, but can't draw anything.

I have tried with driver and then uninstalled driver. It don't work with or without driver and I have tried restart computer etc...

 please help

  • Hi Ivy Wong, I'm sorry for the late reply and to know the issue you are having. Kindly follow the steps below that may help solve your issue:

    1. Please uninstall the tablet driver and make sure there are no other tablet drivers installed on your computer, whether from Huion or other brands. Having multiple tablet drivers installed on your computer may cause issues with the tablet driver.
    2. Unplug your tablet from your computer and reboot your computer.
    3. Install the latest driver for your tablet which you can download from this link, Huion H430P Graphic Tablet Drivers, and follow the installation process from these articles: How to Install Huion Drivers on Windows (Windows computer) and How to Install Huion Driver on MacOS (Mac computer)
    4. After the tablet driver has been successfully installed, please plug your tablet back in and test if the pen works without any issues.

    If you still experience the pen issues after performing the steps above, please send the following information to so we can assist you further:

    • Purchase order number;
    • Product serial number (S/N), which can be found at the back of your unit;
    • Link where you purchased the item;
    • Operating system of computer;
    • Name and version of the program used;
    • Does the issue persist in other programs? If yes, what are those programs and its version?
    • A video that clearly shows your issue (kindly send it through WeTransfer or upload to Dropbox or Google Drive and grant permission to anyone with a link to view it).

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment