Problem with Sai

The pen works in every other program, but in Paint Tool Sai do this thing and i don't know how to fix this, calibration won't work, and every time the pen lose contact with the tablet it change the distance and position

  • Hi Lunis, thank you for reporting your problem with your pen on Paint Tool Sai. May you please try to uninstall and reinstall Paint Tool Sai and check if you will still encounter the same problem? Kindly provide the following information as well so we can further check on this issue:

    • Paint Tool Sai version 
    • Your tablet model
    • Tablet driver version currently installed on your computer
    • Computer operating system
    • What other programs and their versions have you tested?

    Best Regards,

    HUION Customer Support

  • Tablet: KAMVAS GT-156HD V2 Sai: v.1.1.0 When i have "MOUSE" mode everytime the pen lose connection with the tablet the pointer is under the pen and the brush is where the pointer was before and follows keeping the distance. When "PEN" mode i see only the pointer, can't draw and the circle of the brush don't show up. In the properties of sai I checked "disable display scaling on high DPI settings" then the cursor and the brush are "together" but still every time the pen disconnect with the tablet, after "reconnecting" the brush Is where was before and i can draw distant from the brush. Driver: v. When "GAME MODE" is on the brush follows the pointer even after losing connection but the pen sensitivity is not working On other programs like Photoshop or Krita i have no problems. I have 2 monitors and the tablet is the 3rd. Windows 10, and all mine previous wacom drivers are unistalled and I reinstalled sai and the driver, I even disconnected and reconnected the tablet but nothing changed.
  • Hi Lunis, thank you for providing all the information. Turns out we need to further look into your concern. Thus, I will be converting this into a ticket and we will communicate with you through there. Enjoy your day!

    Best Regards,

    HUION Customer Support

  • buenos días, me ha surgido un problema con la tableta gráfica modelo GT-191V2 resulta que al usar el lápiz es como si siempre tuviese presión haciendo un trazo continuo en cuanto se acerca a la pantalla sin que el lápiz presione esta y resulta muy incomodo ¿como lo puedo solucionar? muchas gracias

  • Hola, Abraham Claramunt Navarro , lo que estás experimentando es el problema del desplazamiento del lápiz. Por favor, intente los siguientes pasos:

    1. Cambie la punta del lápiz por una nueva y asegúrese de insertarla firmemente. (Nota: las nubes de polvo en la punta del lápiz también provocarán el problema de desplazamiento del lápiz).
    2. Asegúrese de que no haya otros productos electrónicos como computadoras portátiles o teléfonos móviles cerca. Si los hay, guárdelos y vea si ayuda, ya que el problema de desplazamiento del lápiz también puede ser causado por interferencia electromagnética.
    3. Desinstale el controlador y pruebe la tableta (sin un controlador instalado) para ver si el problema persiste. Esto puede ayudar a determinar si este problema es causado por el controlador.
    4. Si ha dejado caer el bolígrafo accidentalmente. Lo sentimos, pero este tipo de daño causado por el hombre está fuera de nuestra garantía. Le sugerimos que compre un nuevo bolígrafo en nuestra tienda oficial ( Huion Battery-free Pen PW500) o Amazon.

    Si no dejó caer el bolígrafo y los pasos 1 a 3 no resuelven su problema, envíe la siguiente información a

    • Número de serie (que se encuentra en la parte posterior de su tableta)
    • Número de orden de compra
    • Enlace donde compró su tableta
    • Un video que captura claramente tu problema. Puede usar su teléfono para grabar el video y, si el tamaño del archivo es superior a 20 MB, envíelo a través de WeTransfer o cárguelo en Dropbox o Google Drive. Si lo carga, asegúrese de eliminar las restricciones para que cualquiera que tenga el enlace pueda verlo.


    Atención al cliente de HUION


    Hi Abraham Claramunt Navarro, what you are experiencing is the pen hovering issue. Please try the following steps:

    1. Please change the pen nib with a new one and make sure to insert it firmly. (Note: Clouds of dust on your pen nib will also result in the pen hover issue.)
    2. Please make sure there are no other electronic products like laptops or mobile phones nearby. If there are, please put them away and see if it helps, since the pen hover issue may also be caused by electromagnetic interference.
    3. Uninstall the driver, and try the tablet (without a driver installed) to see if the problem still persists. This can help determine if this problem is caused by the driver.
    4. If you have dropped the pen accidentally. We are sorry about that but this kind of man-made damage is out of our warranty. We suggest you purchase a new pen from our official store (Huion Battery-free Pen PW500) or Amazon.

    If you haven't dropped your pen and Steps #1-3 do not resolve your issue, please send the following information to

    • Serial number (found at the back of your tablet)
    • Purchase order number
    • Link where you purchased your tablet
    • A video that clearly captures your issue. You can just use your phone in taking the video and if the file size is more than 20MB, please send it through WeTransfer or upload it to Dropbox or Google Drive. If you upload it, please make sure that you remove the restrictions so anyone who has the link will be able to view it.

    Best Regards,

    HUION Customer Support

  • I have the exact same issue as lunis with my GT-221 pro (windows 10, 1 monitror plus the tablet setup) i tried both mouse and pen mode, in pen mode it's placed correctly but doesn't draw, and in mouse mode it just appears in a different place every time, i also tried the fixes people do with misc.ini and any combination of those but nothing works

  • Hi Triantafyllos Valtasar,are you currently using the Driver_14.8.90 version? May you please provide the specific Windows 10 and SAI versions you are currently using?

    Kindly try the following steps that may help us either resolve your issue or help us determine the root cause, at least:

    1. Uninstall the current driver you have installed, unplug your tablet from your computer then plug it back in. Test if you still experience the same issue without the driver. 
    2. Try using your tablet on another computer and check if you experience the same issue, if you have access to another computer unit.
    3. Try using a different drawing software and check if you still experience the issue. 
    4. Unplug your tablet from your computer, restart your computer and make sure that there are no other tablet drivers installed, whether from us or other brands. 
    5. After restarting your computer, while your tablet is not connected, install the Win10_Driver_14.8.153 version which you can download from this link: Let's try to see if the driver for Kamvas 22 series will resolve your issue. This will still be compatible with your tablet since both models have 8192 pen pressure. When installing the driver, aside from making sure that your tablet is not connected to your computer, please make sure to turn off your antivirus and close all your drawing programs.

    I will reply to your ticket as well.

    Best Regards,

    HUION Customer Support

  • Hi, I'm currently having the same issues as Linus and Triantafyllos Valtasar with the Kamvas Pro 16. I've messed with the settings in sai but nothing seems to work. In pen mode the cursor is correct but I can't draw and in mouse mode I can draw but the cursor always ends up in a different location when I lift my pen. I've also tried to solve this issue by changing the settings in the misc.ini file that people were suggesting online, but nothing works. I currently have the latest driver installed that was on the website and I have sai version 1.0.2 on windows 10. I have a two monitor setup and the tablet is my third. I have tried reinstalling both the driver and sai, but still nothing works. 

  • Hi Ashteria, have you followed the steps found in this article: How to Set Your Tablet Display Work Area? If this won't resolve your issue, kindly try to capture a video of the issue and send it over so I can check on it further and I can forward it to our software engineers.

    Best Regards,

    HUION Customer Support

  • Yes I have the display settings all set up correctly, it's just painttool sai that is having issues. I would also like to mention that I can draw completely fine on clip studio paint, but that's not the main art program I use, sai is. If you need any other info please let me know! Thank you!  

    (6.89 MB)
  • Hi Ashteria, thank you for sending your video and for the additional information. Since your tablet works fine on other drawing programs and on the driver, kindly try reinstalling your SAI and see if it will resolve your issue.

    Best Regards,

    HUION Customer Support

  • Just tried reinstalling sai but it still doesn't work. I'm still having the same issues as before. I've even disconnected and reconnected the tablet as well as reinstalled the driver and nothing works. 

  • Hi Ashteria, the SAI 1.0.2 is an old version. May you please try a newer version such as SAI 1.2.5? Better yet, kindly try SAI 2.0 instead.

    Best Regards,

    HUION Customer Support

  • Buenos días, tengo un problema con la tableta gráfica modelo kamvas 13 al momento de usar Paint Tool Sai. Cuando acerco el lapiz a la pantalla en modo pen, no lo reconoce, y cuando esta en modo mouse, la punta aparece en otra posicion (si tiene presion). He desinstalado e instalado los drivers varias veces sin exito. Ademas de Paint tool sai, en Autodesk Sketchbook, no se me reconoce la presion del lapiz. Cuando desinstale los drivers, la punta estaba donde deberia estar pero sin presion. 

    Version de drivers: 15. 6. 3. 132
    Version de Paint tool sai: 1. 1. 0

    Version de Sketchbook: 8. 7. 1

    Tengo 2 monitores y la tableta es el tercero. Windows 10, y todos mis controladores anteriores de wacom están desistalados y he vuelto a instalar sai y el controlador, incluso he desconectado y vuelto a conectar la tableta pero nada ha cambiado.

Login or Signup to post a comment