Pen pressure doesn't work - Windows 10


I'm using a Huion tablet model WH4109,

I installed the latest drivers and everything's working fine, the pen too, BUT, the pen pressure doesn't work at all and i can't even acces to the pen pressure test on the Pen Display, i've tried to install and reinstall everything 7 times but still doesn't work :/

A little help would be appreciated!

  • Hi Alicia,

    Thank you for reporting your concern. Does your tablet driver show "Device connected"? If it shows disconnected, your tablet was not able to successfully connect to your computer either due to the wrong driver installed or some other reasons. Thus, please uninstall and reinstall the tablet driver. Make sure that the tablet is not connected to the computer when you reinstall the driver. You can download the latest driver for your tablet through this link: WH1409 Drivers

    If you don't  know which driver to install, please contact us through for further assistance, and provide the following:

    • Purchase order number
    • Product serial number (found at the back of the tablet)
    • Link where you purchased the tablet
    • A video showing your issue. You can use your phone in taking the video and make sure you capture the tablet, its connections and the monitor. You can send the video through WeTransfer or upload it to Google Drive and grant permission to anyone with the link to view it.

    Looking forward to your reply or email. Have a great day!

    Best Regards,

    HUION Customer Support

  • Hey fellow artists here.

    I had no issues with my tablet and pen for a long time. But after I switched to a new computer ( Windows 8) my pen pressure no longer was working. The tablet that I had was connected and it worke but the pen pressure didnt register. I was thinking it might have been a problem because of the computer yet even if I changed my computer, nothing changed. I have tried many ways that HUION suggests works. Yet nothings seems to do anything. If you can help me with this it would be a huge help. 

  • Hi Miss Ela, thank you for contributing to this post. May I know what steps you've tried so far? 

    Kindly try the following steps which may help resolve your issue:

    1. Uninstall your current tablet driver you have on your computer and test if your pen works without the driver. Please let me know if it works or not. Please refer to the following article on how to properly uninstall the tablet driver: Uninstall a Program in Windows 8
    2. Disconnect your tablet from your computer and restart your computer.
    3. Install the latest driver for your tablet which you can download from this link: HUION Tablet Drivers. (NOTE: Make sure there are no tablet drivers left installed on your computer, whether from HUION or other brands. Also make sure that your tablet is not connected to your computer while you install the tablet driver. Doing so will cause issues on your tablet's performance.) You can refer to the following article on how to properly install the driver: How to Install Huion Drivers on Windows
    4. After reinstalling the tablet driver, connect your tablet to your computer and test if your pen now has the pen pressure

    If the steps above do not resolve your issue, please test your tablet using the software I have sent to you through WeTransfer. Please follow the instructions provided in the WeTransfer email and send over a video as you do the test. This will help us determine whether the issue is caused by the driver, pen, or tablet. Kindly send the video with the following information to so we can assist you further:

    • Product order number;
    • Product serial number (S/N), which can be found at the back of your unit;
    • Link where you purchased the item;
    • A video that clearly shows your issue (kindly send it through WeTransfer or upload to Google drive and grant permission to anyone with a link to view it).

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment