How to fix “USB device not recognized” error on Huion Kamvas 13?

TABLE OF CONTENTS


When you connect the Kamvas 13 to a computer, you may receive the "USB device not recognized" error .

Cause

This error may be caused if any of the following situations exist:

  1. The power supply of the pen display is not sufficient
  2. There may be a possible conflict between two or more connected USB devices
  3. The driver may have been corrupted or missing 
  4. Windows may be missing other important updates hardware or software issues
  5. Your external drive may be entering selective suspend
  6. There is a problem with the USB port or the port may be broken

Resolution

To resolve this issue, follow the steps in the methods below in the order listed. If the first method does not fix the problem, proceed to the next.

Method 1. Connect the pen display to a power outlet

The issue may be caused by insufficient power supply. Here is what you can do:

  • If you are using the 3-in-1 connection, connect the red USB-A end of the 3-in-1 cable to a USB power adapter, and then plug into a power outlet.
  • If you are using the USB-C to USB-C connection, connect the included USB-C to USB-A cable to a USB power adapter, and then plug into a power outlet.

If your problem still persists, proceed to Method 2.

Method 2: Restart your computer

Sometimes, the issue is fixed by merely restarting your computer a few times. Here’s what you need to do:

  1. Unplug your tablet from your computer.
  2. After a few minutes, restart your computer.
  3. Plug your tablet back in and check if the error still pops up. 
  4. Repeat steps #1-3 a few times.

If your problem still persists, proceed to Method 3.

Method 3: Uninstall USB controllers

This method resolves issues where the currently loaded USB driver has become unstable or corrupt.

  1. Click the “Search” icon on the taskbar and type “Device Manager”.
  2. On the search results, choose “Device Manager” and click “Open” to launch the Device Manager window.
  3. On the Device Manager window, expand the “Universal Serial Bus controllers”.
  4. Right-click the USB controller with the issue and click on the “Uninstall device” to remove it. Repeat these steps for all USB controllers with an issue under the Universal Serial Bus controllers.
  5. Unplug your tablet, restart your computer and plug your tablet back in. Windows will automatically scan for hardware changes and reinstall all the USB controllers that you've uninstalled after the computer starts.

If your problem still exits, proceed to Method 4.

Method 4: Update Windows

This method will install the latest device drivers for your USB external hard drive.

  1. Install the latest Windows updates by clicking on the Start button > Settings Icon > Updates & Security.
  2. On the “Update and Security” screen, click on Windows Update on the left-hand side menu and click on the “Check For Updates” button.
  3. Allow Windows to check for available updates and install them to your computer

If your problem still exists, proceed to Method 5.

Method 5: Disable USB selective suspend setting

This method prevents your USB external drive from powering down.

  1. Select the Start button, type power plan in the Search box, and then select Choose a power plan.
  2. Next to your currently selected plan, select Change Plan Settings.
  3. Select Change advanced power settings.
  4. Select the box to expand USB Settings > USB selective suspend settings.
  5. Select Plugged in, select the drop down menu, and then select disabled.
  6. If you're using a laptop, select Battery, select the drop down menu, and then select disabled.
  7. Select Apply > OK.

If this doesn't resolve your issue, proceed to Method 6.

Method 6: Try another USB port or another computer

The issue may be caused by a defective USB port on your computer or the cable and pen display itself.

  1. Try connecting to another USB port.
  2. Try connecting the pen display to another computer to check if the same problem occurs.
  3. If you have purchased the USB-C to USB-C cable, you can try the USB-C to USB-C cable to check if the same problem occurs.
  4. If you do not have the USB-C to USB-C cable, please contact us at service@huion.com to replace the 3-in-1 cable.
  5. If the 3-in-1 cable has been replaced and the problem persists, the issue may be caused by a defective USB-C port. 

If your issue still exists, please submit a ticket to us for help.

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