Huion HS611 - Device Disconnected on MacOS Catalina

Hello, I am facing a little issue with my table HS611. I can’t get it to connect despite checking all the apps requiered in the accessibility window on MacOS. The drivers I used are the latest one on the website 14.4.5 and 14.4.4, I tried both. 14.4.4 isn’t installing at all. I tried Deleting and reinstalling the drivers multiple times but nothing work. I also changed the cable and tried a different computer which worked. It seems that it is a pretty common problem with macOS Catalina/Mojave. Thank you very much for your time !
  • Hi mcarvalh, thank you for providing the steps you've done so far. Kindly try the steps below:

    1. Try connecting your tablet to another USB port
    2. If you are using an adapter in connecting your tablet to your computer, please try using a different adapter. 
    3. Please check if your USB ports are functioning well by trying it with another device. 


    I will further assist you through your ticket since we will have to test your tablet using our software. 


    Best Regards,

    HUION Customer Support

Login to post a comment