Solved

Problem with HDMI Cable ( Huion Kamvas GT-191 V2 )

Today I got my Huion Kamvas GT-191 V2.  I plugged everything correctly using multiple sources. Connection to the Computer - Done ( Works ) Power - Done ( Works ). Now to the main problem. The HDMI cable that I plugged in correctly using the HDMI for new computers, doesn't transfer anything, its just " no signal " in fact that everything is plugged in, I tried to find source of the problem of it and nothing.

 ( and yes i pushed as hard as I can and cleared the port and i don't have old port type for old HDMI to check if problem is in the cable ) .

 My guesses are that the problem might be in the cable itself, but I want to hear is there any other suggestions in what problem might be. 

I really need help with that.  Thanks.

  • Update: i plugged everything in my laptop and HDMI cable is working on properly , my guesses are wrong again... . But i still need to find out why it's not working on my computer.

  • Hi Ares Boyko, thank you for the update. Since your tablet is working fine on your laptop, and only has issues when connected to your computer, then the issue is caused by the computer's display port. Please see below:

    • Are you using an adapter when you connect your HDMI cable to your computer? If so, please try changing your adapter.
    • If your computer has a dedicated video card, please plug your HDMI cable to the video card; not to your motherboard.


    Best Regards,

    HUION Customer Support

  • I found out what the problem was. Problem was in my computer not in the tablet or cables. Everything is fine, thank you. Tablet works good. 

  • Hi Ares Boyko, I'm glad your problem's root cause has been determined and that your tablet is now working fine. You are always welcome to reach out to us whenever you need our assistance.


    Best Regards, 

    HUION Customer Support

Login to post a comment