Kamvas Pro 16 - Device Disconnected

Hey there... I purchased a Kamvas Pro 16 about a month ago and it works and then it doesn't. Meaning that I often have to turn it on and off several times before the driver software will read that it is connected.  Once I do that, and the software reads device connected and it works great, but it's so unreliable and turning it off and on 4 to 5 times each session seems like putting needless wear on the monitor.


I'm using an iMac (late 2015) and Catalina version 10.15.4


Thanks for any help!

  • Hi Nathan Brown, thank you for posting your issue. Usually the "Device Disconnected" issue may be caused by the cable not securely plugged, defective cable, defective port/s (computer and/or tablet), or incorrect driver version installed. Since it works after turning it on several times, it means that you have the correct driver version.  Kindly try the following:

    1. Unplug and plug the cables back in and make sure that they are securely plugged.
    2. Try plugging the USB end of the 3-in-1 cable to a different USB port. Make sure that the USB ports are working well.
    3. Try connecting your tablet to another computer and check if you still encounter the same issue.
    4. If you are using an adapter, try using a different one or try connecting without it, if possible.
    5. Try installing the latest driver for your tablet which you can download from this link: Huion Kamvas Pro 16 Tablet Display Drivers. Please make sure that you properly uninstall the current driver you are using from the Control Panel or the Huion Tablet Uninstall app. Restart your computer before installing the latest driver and make sure that your tablet is not connected to your computer, your antivirus is turned off and all your drawing programs are closed when you install the driver.


    If you've done the steps above and still experience the same issue, then it is possible that your 3-in-1 cable may be defective. We will further assist you through your ticket.


    Best Regards,

    HUION Customer Support

Login to post a comment