My Pen for my GT-191 isnt working

The pen for my GT-191 has stopped working! It wont charge and it wont interact with the graphics tablet at all. I was given 2 pens with the tablet when i brought it. One of them worked fine, but the other one didn't work (1/2 of the pens worked out of the box). I lost the original charger for the pen, so i thought that, that was the issue. However, when i tried to charge the pen, there was no LED indication to show if it was charging. And when i tried using it after, it wouldn't work. Could you please help me?


The link to the charger i brought -

  • Hi  Aryan Kora, we are sorry to be informed about the problem you have encountered. 

    To troubleshoot, please check the following so we can help you further:

    1. Can the pen move the cursor or draw after being fully charged or while connected to the charging cable?
    2. Does the driver panel show "Device connected" while using the pen?
    3. Does the pen work with or without any driver installed?

    Best regards, 

    HUION Customer Support

  • Sorry for the long wait.  I didn't have time to check up on the issue. I found out that the charger that i ordered wasn't working as intended, so i had to remove some of the material on the end of it, because the metal bit wasn't going into the pen's charging port properly. Apparently the pen was just out of battery! thanks again for the help.

  • Hi Aryan Kora, we're glad to know that your pen is just out of battery. Feel free to reach out to us through if you have any issues or concerns. 

    Best Regards,

    HUION Customer Support

Login to post a comment