Solved

Kamvas GT-221 Pro: Pen not working

I bought this tablet a couple of days ago and tried to install it. Now, it doesn't recognize the pen at all. I tried everything. I did everything according to the manual, then both reinstalled the drivers and restarted my PC MULTIPLE times. It worked once for a short period of time and then stopped again and now it doesn't work at all and I can't get it to work! WHY? Even while charging it it doesn't work at all.
  • Hi Sasa Blissful, thank you for posting your concern and I'm sorry to know about your pen issue. Have you installed the tablet driver? And does the tablet driver show "Device connected"? Kindly try the following steps so we will know the root cause of your issue:

    1. Please uninstall the tablet driver and make sure there are no other tablet drivers installed on your computer, whether from Huion or other brands. Having multiple tablet drivers installed on your computer will cause some issues on your tablet's performance such as pen not working.

    2. Unplug your tablet and plug it back in. Then test if the pen works well without the tablet driver. If it does, then the issue is with the driver. If it still doesn't, it may due to other causes.
    3. Unplug your tablet from your computer again and reboot your computer.
    4. Install the latest driver for your tablet which you can download from this link, Huion GT-221 Pro Tablet Drivers, and follow the installation process from these articles:

    5. After the tablet driver has been successfully installed, please plug your tablet back in and test if the pen works without any issues.

    If you still experience the pen issues after performing the steps above, please provide the following information to service@huiontablet.com so we can assist you further: 

    • Product order number;
    • Product serial number (S/N), which can be found at the back of your unit;
    • Link where you purchased the item;
    • Operating system of computer;
    • Driver version installed;
    • A video that clearly shows your issue (kindly send it through WeTransfer or upload to Google drive and grant permission to anyone with a link to view it).


    Best Regards,

    HUION Customer Support

  • I tried all that and it still doesn't work. Neither the newest driver, nor any others. And all of the advice mentioned as well. It never works. It doesn't show up!

  • I kinda had the same problem. The pen on my GT 220 V2 didnt work at all no matter what I tried. I figure it must be that the drivers of Huion and WIndows are bugging each other out and causing issues. What i did to fix it and i may have just been lucky, was just completely wipe the huon drivers. Go into your folder and just delete the whole file. Restart and see if that helps. it sucks that the it has to be this way but it was the only way I was able to get my monitor to register my pen again. Still works as of this moment.

  • Hi Stephanie Barrett, thank you for contributing to this forum. Your solution in reinstalling the tablet driver is right. Sometimes, that is the only thing you need to do, especially if there are some updates on the computer's operating system.


    Hi Sasa Blissful, if it still doesn't work, please provide the following information to service@huiontablet.com so we can assist you further: 

    • Product order number;
    • Product serial number (S/N), which can be found at the back of your unit;
    • Link where you purchased the item;
    • Operating system of computer;
    • Driver version installed;
    • A video that clearly shows your issue (kindly send it through WeTransfer or upload to Google drive and grant permission to anyone with a link to view it).


    Best Regards,

    HUION Customer Support

Login to post a comment