Pen right clicking

I bought a Huion Kamvas 13 less than a month ago and everything was going just fine. Recently i’ve been facing a problem where my pen would just right click whenever i press on the screen, but a simple restart did the trick. But today, a simple restart wouldn’t fix it at all. I tried reinstalling the driver but it would only work for a brief moment. The pen could work properly on 2 situations. First is when i don’t install the driver and second is when i uncheck windows ink option. But doing so will remove the pen’s ability to apply pressure sensitivity, which i need. Is there a way to fix this issue? Im using a windows 11 Laptop and Clip Studio Paint

2 people have this problem
  • Hi Levi, since the pen works properly on certain situations and the pen pressure works without the driver, it means the issue is with your setup; either with the driver or Clip Studio Paint. Thus, kindly try the following steps: 

    1. Install the latest tablet driver version for your Kamvas 13 tablet display. Please ensure that your tablet display is not connected to your computer, your antivirus is turned off, and your Clip Studio Paint and all drawing programs are closed while installing the driver.
    2. Connect your tablet and open the driver. Go to Digital Pen > Press Key > ensure to put a check on "Enable Windows Ink". 
    3. On the driver still, go to Settings > General > click "Administrative privileges" button if you see it. You can skip this step if you don't find the said button.
    4. Open your Cli Studio Paint software and go to File > Preferences > "Tablet" tab > choose "WinTab". 
    5. Check if you now have pen pressure and if the pen is still right-clicking. If needed, try restarting your computer.

    Please let me know if the steps above don't resolve all your issues.

    Best Regards,

    HUION Customer Support

  • Hi Orliza,

    I have the same (or very similar) problem as Levi, just with a Kamvas 16 Pro 2.5k, on Windows 11.
    It was working earlier with Windows Ink enabled, on the Windows desktop in general, and also with pressure sensitive pen within all applications (Krita, Photoshop, Clip Studio Paint, Concepts).
    Recently the pen stopped working, except for within the Huion App itself (there it properly works, including pressure tests), but anywhere else hovering over the display wouldn't move the pointer, pen presses result in right clicks, and I cannot draw at all.

    Disabling the 'Windows Ink' checkbox allows using the pen, and changing the mode to 'WinTab' instead of 'Windows Ink' lets some applications that have this option to use the pen pressure, but other ones (eg. Concepts, Fresco, Sketchbook), supporting Windows Ink only, stopped working properly. Also I need to change the applications' tablet settings whenever I want to switch between using the Kamvas and the 2-in-1 laptop's own display & pen, which is very inconvenient (especially in Photoshop's case, where an external file edit + restart is needed).

    I've tried all the usual suggestions I could find only: restarting Windows, reinstalling the driver, allowing 'Administrative privileges', pressing the repair on the 'software diagnosis' window, with no luck.

    My suspicion is either a new version of the Huion driver is defective, or there were some Windows Update that made the Windows Ink not working with Huion together.

    For reference: Huion Table version v15.6.3.132; Kamvas Pro 16 GT1602, fw version M20q_21115; Windows 11 Pro ver 22H2, OS build 22621.1778

  • Hi Attila, I'm sorry about your pen problems. Kindly try the following steps:

    1. Uninstall the current tablet driver from your computer, and ensure there are no other tablet drivers installed, whether from us or other brands.
    2. Download the driver from this link: Driver_v15.7.4.183
    3. Disconnect your tablet from your computer, turn off your antivirus, and close all your drawing programs.
    4. Right click on the driver file, and click "Run as administrator".
    5. Reconnect your tablet after the driver is installed. If necessary, restart your computer.
    6. When you open the driver again, please ensure to allow "Administrative privileges" to your driver.

    Please let me know if this driver version and the steps above don't resolve your issue.

    Best Regards,

    HUION Customer Support

  •  Hi! I'm also asking here because I have no idea what to do, but my computer did the update for windows 11 and now my pen tip keeps right clicking, I have a H610pro.

    I've tried anything I could think of but nothing works

  • Hi Luis, I'm sorry the steps you tried didn't work. Our H610Pro tablet has 3 versions: H610Pro (2048), H610Pro (8192), and H610Pro V2. To determine which version you have, kindly provide the first 7 digits of your serial number, which can be found on the back of your tablet, and starts with S/N. 

    Have you tried using your tablet without the driver? Does it work well? If you haven't tried it, please uninstall the tablet driver currently installed on your computer, unplug your tablet from your computer, then plug it back in. Open your drawing or writing program and test if your tablet works well without the driver.

    I look forward to your reply.

    Best Regards,

    HUION Customer

  •  it's a H610Pro 2048, sorry, I bought the tablet a few years ago, and unfortunately the sticker with the serial number is not on it anymore.

    I tried uninstalling the driver but it changed the tablet back in right handed mode (I'm left handed) so I have trouble with the cable not being long enough since the plug for it is now further away from my computer tower, and I can't see what I'm doing with my pen because the cursor disappears when i use it.

    at least the pen tip does act as a left click again so that problem is fixed, but unfortunately I have two new things that are wrong now.

  • Hi Luis, thank you for your clarification. May I know the driver version you installed and your computer operating system? 

    Based on your tablet model, the latest compatible driver is version 12.4.2 for Windows, and 12.2.2 for Mac. If you are using a version 14 or 15 driver, this is why you are having those issues. 

    Here's the download link to the correct driver versions: Please choose Pen Tablet > Huion > H610PRO(2048).

    Best Regards,

    HUION Customer Support

  • I would like to add that I also have the same problem ever since my Windows updated. In my case, I am not able to properly use my pen in any situation. I am using the Inspiroy H640P model.

    I have already uninstalled and reinstalled the driver as well as testing diagnostics (everything seemed to work properly within the diagnostics testing), so I think it should be the new Windows update messing with the driver in some way. For reference, my Windows updated just this morning and my pen worked fine last night before the update. 

    (3.74 MB)
  • Hi J, if issues happen after a system's update, you are right; the update may have messed with the driver. Thank you for sending the videos. Since I don't see your pen in the videos, am I correct to assume that your pen taps don't work properly on CSP's menu and on the browser? If that's your issue, please try the steps below:

    1. Uninstall your tablet driver, disconnect your tablet from your computer, and restart your computer
    2. After restarting, don't reconnect your tablet. Download the latest driver version for your tablet from this link:
    3. After downloading the driver, turn off your antivirus and ensure no drawing programs are running. Then install the driver.
    4. When your tablet driver shows "Device disconnected", connect your tablet to your computer and go to Settings > General tab. If you see the "Administrator privileges" button, click on it to give your driver the necessary access to your computer.
    5. Go to Digital Pen > Press Key > enable Windows Ink
    6. Open CSP and go to File > Preferences > Tablet > check if you have "Tablet PC" selected. Then try using your tablet. If you have issues, go back to the preferences and choose "WinTab" instead, then check.

    Please send an email to if you continue to experience issues.

    Best Regards,

    HUION Customer Support

  • Hi I'm back!

    so the thing is, I found a different driver on another topic which seemed to work for a while, but today the pen is back to right clicking.

    Also, I did try many times to reinstall the driver that you sent me here, even before the other one, but this one has never fixed the issue.

  • Hi Orliza,

    Sorry for not coming back earlier, had the time to test it just now, but I can verify now that the v15.7.4.183 driver seems working for me. I tested with the previous again before installing it, and it was still defective as earlier, but with this new driver all seems good(so the fix was likely in the difference in the drivers). I needed to eventually restart the machine, but didn't need to press the 'Administrator privileges' button after reboot.
    Just to clarify what I mean by 'working' (for all others): I can use the Kamvas again as a Windows Ink device in CSP or Krita, pressure and tilt working fine. I can switch between using the Kamvas and the builtin tablet screen seamlessly without needing to change drivers or anything.
    WinInk-only programs like Concepts and Fresco also work as expected now.

    Many thanks,

  • Hi Luis, I'm sorry that your pen is back to right-clicking. May I know which driver version was it? Since you have the H610Pro (2048) model on a Windows 11 computer, please try the following:

    1. Uninstall the current tablet driver on your computer, disconnect your tablet, and restart your computer.
    2. Reconnect your tablet and try using your tablet without the driver. Check if you still encounter the same right-clicking issue. 
      1. If you still do, then the issue is not about the driver. It is possibly caused by a defective pen. Rechargeable Pen PEN80.
      2. But if you don't experience the same issue without the driver, then the issue is caused by the driver. Please proceed to #3 below.
    3. Disconnect your tablet from your computer again, and download this driver version: Driver v12.4.3 (for tablets with 8 press keys and 16 soft keys). Please follow the steps for version 12 driver installation from this link: How to Install Huion Drivers on Windows. (NOTE: Ensure your tablet is not connected to your computer, your antivirus is turned off, and your drawing programs are closed while installing the driver.)

    Best Regards,

    HUION Customer Support

  • Hi Attila, I'm glad the driver now works well with your drawing programs. Thank you for your confirmation. Feel free to let us know if you need further assistance.

    Best Regards,

    HUION Customer Support

  • I'm having a similar problem. My pen sometimes works in the middle but not on the edges when I go to close something out. The program I use is MediBang. When I try to draw it thinks I'm right-clicking all the time. It only pops up the color picker tool. I had the H610PRO for two years without any issues, and then the right-clicking started. I thought my tablet might have just been old. I upgraded to the Kamvas 13 thinking it would solve my problem. But straight out of the box I'm having issues.

Login or Signup to post a comment