Pen pressure now Working (H430P)

I have this tablet for 2 years now, and recently just update its driver. So when I test it out in the pressure test in a driver setup, it can doodle but the pressure sensitivity doesn't work. I unplug and plug it in, it still doesn't work. 


  • Update: It seems that after sent my conflict regarding this matter, the pressure sensitivity works again in my art platform and in Snipping Tool. Although it corresponds late whenever I use it on Medibang.

  • Hi lm pantomime, thank you for your feedback. What is the version of your driver? Is it Driver_15.5.3.444. It may be caused by not updating the driver well. Kindly follow the steps below to reinstall Driver_15.5.3.444 if your operating system is Windows:

    1. Exit the Huion driver, close all running drawing programs, turn off your anti-virus software.
    2. Uninstall all Huion drivers from the Control Panel.
    3. Unplug your tablet from your computer.
    4. Download and install the latest driver from the Huion Official Website.
    5. Plug the tablet back in.

    We also would like to clarify with you that it corresponds late whenever you use it on Medibang. Do you mean the pen lags when you draw?

    Best Regards,

    HUION Customer Support

  • Good day, I follow your instructions and it worked. Thank you for your service!

  • Hi lm pantomime, I'm glad that your issue has been resolved. Feel free to contact us again through whenever you need our assistance.

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment