H1060P Pen tablet doesnt' work

Hello

I'm using H1060P for two years almost and I was extremely satisfied. 
Two days ago my pen tablet stopped working properly. In the beginning, It was simple lags, but now pen doesn't work at all. Buttons are not working properly too. Tablet barely feels the pressure of pen(how it should be). I thought the reason of this could be a new update of Windows (it happened 2 days ago). I uninstalled an update but still nothing changed. 

I'm using the newest drivers, I tried to enable "windows ink" option,  USB ports are ok, tablet cable is working as well.

INSIGHTS
-Tablet is working. I can push the buttons and they are working how they should work. 

-When I remove a NIB from pen tablet I am able to move the cursor(and buttons are starting to work as well - with a little bit of lag). When I place the NIB back it starts to be "dead" again. 

-Problem started with simple-short lags, vertical and horizontal lines appeared when I was drawing, tablet didn't read fast movement of pen

-I'm using the same drawing app as before. 

Due to my work and University I'm using tablet every single day for few hours. Tablet and pen as well are safe, they are not damaged at all. All problems I mentioned started two days ago. 

I wish to go back to work as soon as it is possible so I would be grateful for help. 
Best regards.

  • INSIGHTS 2

    - Tablet doesn't work without drivers (even cursor)

    - All NIBS are in perfect shape. I tried every nib I have, but still, it is not working. 

Login or Signup to post a comment