GT_191 Crashes my iMac when connected

I have had my tablet for about a year and a half now. I have had no previous issues with it. In December of 2020 I experienced some trouble after the updates from Apple. After some trial and error I ended up deleting the drivers and re-installing them. The first few times this did nothing. I later found on another thread that you need to uninstall the application then go into the ~/Library and delete some more files from a couple of folders there and then delete your trash, restart and then re-install the application. This seemed to work for me at that time. However, when it did begin working again it had a very noticeable drift of my pen nib to the curser that I couldn't fix. I again researched the issue and re-installed an older version of the app and it worked. 

Here is my main gripe and concern about the GT-191 tablet. It worked fine on El Capitan OS but after that update it has continually crashed my iMac. (Randomly) It could be  right after start up and it could be when I leave to go get a drink or it could be when I am working on an illustration. My Mac says it encountered a problem and had to shut down. I unhooked everything that is connected to my computer ie. hard drives external monitor, USB hub, everything. Then slowly over the past month have been implementing the slowly back. Everything works as it should until my tablet gets connected then with in minutes my Mac shuts down or locks up. This is with and without anything else connected.

Here is my specs:

macOS Big Sur version 11.1

iMac (Retina 5K, 27-inch, 2019)

Processor 3.6 GHz 8-core Intel Core i9

Memory 64GB 2667 MHz DDR4

Startup Disk Macintosh HD

Graphics Radeon Pro Vega 48 8GB

If you can offer any help it would very much be appreciated. I currently have work that I need it for but can't have it connected because of this issue. Thanks in advance for any help!

1 person has this problem
  • Hi Clint Silverhorn, thank you for providing the details of your issue, the steps you've done, and your computer specs. It is possible that you are using an old driver version on your MacOS Big Sur computer. Please try using the attached driver version.

    Best Regards,

    HUION Customer Support

  • Got exactly this same problem, except mine is using the latest version of Ventura. I downloaded the latest driver from Huion's website.

  • Hi Victor, I'm sorry that you are experiencing the same problem. Kindly follow the steps below and see if it will resolve your issue:

    1. Properly uninstall the tablet driver currently installed on your computer. You can follow the applicable steps from these links:
      1. How to Uninstall the HUION MAC Driver V13 or V14 Properly
      2. How to Uninstall Version 15 Driver (MacOS)
    2. Go to Applications > Utilities > Acitivity Monitor > search tablet > delete all files and folders related to our company. Ensure that you don't have any tablet drivers left on your computer, may it be from our brand or others.
    3. It's better to restart your computer to refresh the system.
    4. Download the latest driver version from this link: Huion Drivers. If you need to select, just choose Pen Display > Product Series: Huion > Product Model: GT-191.
    5. Follow the instructions on how to install the driver from this link: How to Install Huion Driver on MacOS. Then test your tablet again.

    If the steps above do not resolve your issue, please let me know so I can create a ticket for you, and provide the following:

    1. Your MacOS Ventura version
    2. The tablet driver version you installed

    Best Regards,

    HUION Customer Support

Login or Signup to post a comment