MY PEN OR DRIVERS ARENT WORKING

I set up my tablet as instructed and it work fine for like 20 minuets then the tablet wont register the pen. And the only way for it to recognize the pen is of I turn it off then turn it back on 

When I first set everything up I was able to use clip paint but now it wont let me use it. I have tried leaving a ticket but it was closed before I was able to get any real help. 

Has anyone else had a similar problem and if so how did you fix it? I have tried re download my drivers and everything still no fix.

  • Hi Katbanks60, may you please provide the following:

    • Your tablet model
    • Version of the tablet driver you installed
    • Your computer's operating system and version
    • The version of Clip Studio Paint you are using


    Kindly try the steps below that may help resolve your issue:

    1. Properly uninstall your tablet driver and make sure there are no other tablet drivers installed on your computer, whether from our company or other brands. 
    2. Unplug your tablet from your computer then plug it back in. Test if your pen works without the driver. (NOTE: Your pen won't work without a driver if you are using MacOS Catalina 10.15 or Big Sur 11.0)
    3. Unplug your tablet from your computer again and restart your computer. 
    4. Reinstall your tablet driver. Make sure that your tablet is not connected to your computer, your antivirus is turned off, and your drawing programs are closed when installing the driver.


    Please reply to your ticket if the steps above do not work and provide the requested information in your ticket and those above.


    Best Regards,

    HUION Customer Support


Login to post a comment