Kamvas 13 Keeps Disconnecting and Reconnecting

Hey there! Recently bought the Kamvas 13 from Amazon and immediately fell in love with it but recently its been having issues staying connected. I'm using the 3-1 cable and it will start a cycle of disconnecting and reconnecting. The screen will stay on but the led light will be constantly turning off then on with the windows noise signaling a device being disconnected. I've tried updating the driver (none available), reinstalling the driver, unplugging the tablet and plugging it back in but it always ends up doing this. Is this a driver issue? Cable issue? Bad tablet?

32 people have this problem
  • Another good config to add to the mix:

    Dell Vostro 3550, Intel i5, 8GB, Win 10 Pro, 153 revision drivers from clean.  Get the occasional disconnect beep but doesn't affect operation of the tablet.

    But another variable to test.  All my good ones use only local machine logons, NOT Microsoft windows live logons.  Could that be getting in the way??  Time for YET another rebuild!!

  • It's not Microsoft online accounts.  Rebuilt the Latitude with local accounts only and problem as bad as ever.

    So that leaves Windows 10 Pro + Revision 153 as the stable version.

    Off to get another Pro licence, more follows...

  • No joy on the Pro Upgrade.

    There is something about this machine that the driver doesn't like.  Full spec is:

    Dell Latitude E7450
    Processor      : Intel(R) Core(TM) i7-5600U CPU @ 2.60GHz   2.59 GHz
    Memory         : 8.00 GB RAM
    Graphics       : Intel(R) HD Graphics 5500
                   : NVIDIA GeForce 840M
    Disk           : SK hynix SC210 mSATA 256GB
    OS             : Windows 10 Pro 20H2, Build 19042.685, Experience Pack 120.2212.551.0
    BIOS           : A24
    USB Controllers: Mobile 5th Generation Intel(R) Core(TM) USB EHCI Controller - 9CA6
                     Intel(R) USB 3.0 eXtensible Host Controller - 1.0 (Microsoft)


  • Just bought a kamvas 13 and this issue happens all the time to me. I tried all the different driver versions available from huion, and the older ones shared in this thread, but to no avail. The tablet keeps disconnecting and reconnecting indefinitely, with the LED flashing and the pen not responding. The only fix to this has been to end the huion driver process from task manager. Im running on windows 7 home premium 64 bit, tablet is connected directly to an AMD rx580 8bg if that matters. My tablet serial number: A8DE6SH03561

  • Oh yeah I forgot, the Beta drivers work semi ok without major crashing, but then there is no pen sensitivity, which kind of renders it useless regardless.

  • I had a similar problem that was so frustrating I almost returned the unit for a Wacom. Hooking it up to a PC using the 3-1 cable worked fine but as soon as I hooked it up to a tablet or phone it would say connecting disconnected connecting disconnected like every second constantly. I tried several different USBC cables and power bricks to no avail. I also do not like that the USBC cables do not fit in so easily. So I figured I didn't have a "full featured" usbc cable like they say you need so I ordered one directly from Huion. I arrived very fast considering it came from China, so I'll give them that. When using it, the same problem happened. Connect disconnect. Drivers, Beta Drivers, 2 different phones, 2 different tablets, no difference. So I decided to bring it from my wifes office to mine and try it where I can search the internet. When I hooked it up to my Anker USB hub it worked without issue!!! What? So I tried a few more power bricks and BOOM. One of them worked. Now it works fine no disconnects at all. 

    The power brick that worked just says on it 

    Model: SW-050--5-150

    Input: 100-240v AC 50/60 Hz

    Output: 5vdc 1500 mA

    The other power bricks I tried were all either Samsung, Amazon, or Apple. They Samsung says:

    Input: 100-240 v - 50-60 Hz 0.50 A

    Output: 9.0v == 1.67 A or 5.0 v == 2.0 A

    Not sure the difference but WHY DOES HUION NOT INCLUDE THE < $1.00 power brick???? For that matter why do they not include the USB C cable and any instructions or software either... Come on guys, basic 101, its like what a dollar extra? Pass on the added cost to the consumer, the frustration alone is worth the extra cost.

    Hope this helps, it helped me.

    Oh and BTW HUION support is useless, they never got back to me. If I could do it again I definitely would not buy this brand. SO FRUSTRATING.

  • I can confirm that I've been using a dual voltage fast charger USB plug. I have a single voltage 5v adapter I will try and see if the problem is still there. Thanks for the letting us know what you have found!
  • Won't be exclusively the power brick.  I have a brick that works on four machines but not the one machine I actually want it to work on...

  • https://www.youtube.com/watch?v=u3C40eBwLzI


    Sometimes every 4, 5, or 10 minutes, Huion disconnects and reconnects even though I don't do anything.

    The video above is when I open and close Google Chrome repeatedly

    The result: sometimes disconnects, sometimes runs normally

    I always monitor everyday discussion of this issue, from when it was one page until now.

    hopefully, it will be resolved soon.....

    "Google translate"

  • Hi Calum Scott,  orman997, and Noka Wan, thank you for adding your observations. These are duly noted.

    Hi Russ Katz, we apologize for the delay in our reply. We currently have high volume due to the holidays and rest assured we will reply to your ticket as soon as possible. Hoping for your patience and understanding.

    And thank you for your observations as well. I will forward this to our Technical Department so they can look into this variable.

    Best Regards,

    HUION Customer Support

  • So tired...
    I've been in contact with Huion support over mail now for weeks. 

    First they thought it was the cable,  they sent me a new 3 way USB cable for free since I was within warranty but still.

    The display keeps disconnecting and reconnecting. The screen image is not flashing or anything. Just the driver flipping out.

    Opening up Devices and Printers, it shows that the tablet is reconnecting almost every minute when I am not using the pen.
    I can see that when it disconnects there is a new device showing "WPM USB" and then it goes back to normal "tablet monitor".

    Now they want me to send it back to them and they will send me a replacement unit. They told me that they will stand for the shipping but I'll have to pay for it myself first.
    I feel that it will be way easier to return it to amazon instead, and I dont trust them either since I can see how many people having this same problem without actually concidering that this actually is a driver problem...

    This is most definitely a driver problem since I dont have this disconnecting problem in OSX Catalina.
    I had loads of other problems in OSX tho... Some of the problems are fixed now with the latest beta release, now the tablet is working really well on my OSX install instead.
    But honestly I am using my mac as a dual boot system and really need this for my Windows 10 install too.

    Guys try this. leave the pen close to the display so that the display recognizes (feels) the pen. Let the computer be, the dissconnecting and reconnecting will probably not occur while the screen senses the pen.
    For me this was the only way to not get the screen to reconnect while not using the screen.
    Still not a fix tho and this is horrible support from Huions side...

  • Dont bother to get replacement unit, i got mine replaced from my local distributor.. and the new unit still facing the same disconnecting problem. (and now they insist that the replacement unit is "working properly", and they tell me to try on the other computer which i don't have)

  •  so i don't know if anyone's said this, but I've noticed something about this issue, it only happens when its left IDLE, but the moment i put my pen up to it, suddenly it stops, so it must be something about the Tablet's sort of Idle programming that's causing this

  • I ordered Huion Kamvas 13 last December 25, 2020, from Lazada Philippines. It was working fine for a week and then it suddenly won't turn on. I plugged all the cables properly but it doesn't work at all. The red light in the power button is also not showing. Can you help me with this? 

    I also saw a video regarding this issue, and we're having the same problem. https://www.youtube.com/watch?v=kByIOEGNEwY&list=LL&index=1

  • Franchesca Del Mundo - you should start a new conversation or a support ticket.  That is a different issue from this topic.