Kamvas 13 Keeps Disconnecting and Reconnecting

Hey there! Recently bought the Kamvas 13 from Amazon and immediately fell in love with it but recently its been having issues staying connected. I'm using the 3-1 cable and it will start a cycle of disconnecting and reconnecting. The screen will stay on but the led light will be constantly turning off then on with the windows noise signaling a device being disconnected. I've tried updating the driver (none available), reinstalling the driver, unplugging the tablet and plugging it back in but it always ends up doing this. Is this a driver issue? Cable issue? Bad tablet?

32 people have this problem
  • @Marven Thanks for the update. This seems like a driver issue to me. I'd been sent new cables (they were pretty good about that) but the issue persisted. Today, I downgraded from the latest driver on their website to the one shared by Orliza and just about 15 min in, I haven't had a connect/disconnect cycle yet.

    I hope they can fix the driver issue, otherwise i dont think this tablet will work in the long term.

  • I've opened a ticket too, but just to add mine to the mix:

    S/N: A6DE8SH

    I've been through all the suggestions in the thread - still disconnecting.

  • Update: I installed the driver (HuionTablet_WinDriver_v14.8.153.1344_HID) on the 25th Dec and this seemed to solve the issue of the connecting/disconnecting. However, I noticed after extended use (4-6 hours) - the tablet disconnects and does not connect. The display works but I have no pen functionality.

    Today, the Huion software suggested a driver update (HuionTablet_WinDriver_v14.8.166.1482_HID). I have installed this revision but the same issue has occurred. The tablet has disconnected after an extended period of use.

  • I'm having the same issue i'm using driver that was posted and have it connected directly to my Rtx 2080 with the usb-c cable and the tablet is also plugged in for power

  • I recently got my Kamvas 13 and I'm having the same disconnecting / reconnecting issue. I tried every single driver, I've tried killing HuionTablet.exe in task manager, I've tried connecting the power USB to an A/C adapter, I've tried every single USB port on my PC, nothing fully works. I'm ALWAYS interrupted by it suddenly disconnecting while I'm in the middle of drawing a line or selecting a tool. It will be fine for anywhere from 1 minute to an hour and suddenly start disconnecting constantly, sometimes disconnecting every 2 seconds for up to 5 minutes straight (I'm not even exaggerating). 

    S/N is A7DE6SH

    Random information: 

    • After disconnecting the tablet Windows says "The last connected USB device has malfunctioned."
    • Every time it disconnects, TabTip.exe from Windows Ink Workspace is running and killing that makes the tablet more stable. Additionally, fully disabling Windows Ink Workspace made the disconnects happen much less often, but they still happen quite often.

  • I seem to have two situations that work. And you're not going to like it...

    One Dell Latitude, oldie but well spec'd, Windows 10 Pro, all bang up to date with updates and integral drivers.

    One Lenovo W540, well spec'd, Windows 10 Pro, all bang up to date with updates and integral drivers.

    The latitude works fine, I get the disconnect bongs but it stays connected and stays working.  This was my debug mule against another Latitude which is where the problem lies.  If you have one that works and one that doesn't you should be able to find the problem right?  Well...  Nearly...

    So the other Latitude, the one where it doesn't work, again, bang up to date with OS updates and integral drivers.  This time Windows 10 Home which shouldn't really be a problem.

    More background:
    The Latitude with the problem, was a clean install of windows.
    I installed the V15 driver, latest and greatest.  Problem started.
    I downgraded to the V14 drivers on the Website - Driver_14.8.166.1482_HID. Problem continued.
    Tried all the other tricks in the thread including the revision 153 version which took about an hour to get off the website!!.  Problem continued.
    Clean installed Windows again, total wipe and start from scratch, installed Driver_14.8.166.1482_HID.  Problem continued.
    Gave up at that point.

    Until today!  My mini display port to HDMI dongles arrived from Amazon...
    Went to get the drivers from Huion website, which is bust so I gave up because I knew I had the zip file on the Latitude that works.  HuionTablet_Win10_v14.8.153.1344!!!

    Copied them over, installed on the Lenovo, works a treat.

    Working hypotheses at the moment are:
    1) All drivers on current Win 10 after the 153 revision are bust and not only that, they leave artifacts that prevent successful downgrade.  OR
    2) Huion drivers don't work on Windows 10 Home.

    I'll test it tonight by trying a registry cleaner on the not-working Latitude because if that finds something that allows a successful downgrade, that's going to be a lot better for you guys than a full ground up rebuild on your machines!

    Failing that, I'll do the ground up rebuild and see if Home is the fundamental issue.

    Wish me luck!

  • @calum Scott, do you have any way of sharing that older driver version?

    Would be very interested if downgrading works better after registery cleaning. 

  • Just wanted to leave this here: Mine is Windows 10 Pro and it has the issue.

  • @Meowmaritus - thanks, that points to my option 1 then!

  • @Hendrik Vingerhoet, seems this board software doesn't like links from non-mods...  email me - my name with no spaces at yahoo dot com and I'll send you the link.

  • I'm having the same problem I've tried all the fixes and the only one that seemed to work was the downgrade suggusted but then again I'm only like an hour in and I'll comment again if theirs any updates to that with my serial number.

    I've had this problem with this device since I got it tho back in like August but now it's just gotten to a point where I realize it's not just because of a bad computer as I'm using it on a brand new computer and it still has the problems.

    Also it does work just find without the actual app on which is annoying as it's not really any use to me if I can't custom program the buttons.

  • Ok it just did it again but at least this time it stopped far sooner than it has in the past so.. progress?

    S/N: A6DE6SH04232

    Side bar, I got it off of Amazon

  • Hi everyone, I would like to thank you for all the information you've shared in this thread. We will let you know as soon as we have any updates on a fix for your issues. As of the moment, please continue to provide any relevant information in this thread. We thank you all for sharing your observations. Hoping for your patience and understanding as we do our best to find a solution to this issue.

    Best Regards,

    HUION Customer Support

  • Attempted to clean up and reinstall on the non-working Latitude (Win 10 Home).  No joy.  Same problem.  It may well be that there is more to the cleanup than I know...

    ...so I went for the full reinstall of Win 10 Home.  Completely clean, everything bang up to date (integral drivers and windows updates, all device manager issues resolved etc.), clean install of revision 153 - no joy.

    So the only configurations I have working are:

    Dell Latitude 6430u, Intel i7, 16GB, Win 10 Pro, Huion 153 revision from a completely clean install.

    Lenovo ThinkPad W540, Intel i7, Win 10 Pro, Huion 153 revision from a completely clean install.

    Current hypothesis is:

    - all Huion drivers beyond 153 have a fatal bug on current windows 10 SKUs.

    - the Huion 153 revision and beyond have a fatal bug on Windows 10 Home.

    - possible hardware fault on my latitude E7450 usb root hub.

    If anyone has the ability to test the clean installation of 153 on a Win 10 Home machine I'd be VERY VERY grateful!