Kamvas 13 Keeps Disconnecting and Reconnecting

Hey there! Recently bought the Kamvas 13 from Amazon and immediately fell in love with it but recently its been having issues staying connected. I'm using the 3-1 cable and it will start a cycle of disconnecting and reconnecting. The screen will stay on but the led light will be constantly turning off then on with the windows noise signaling a device being disconnected. I've tried updating the driver (none available), reinstalling the driver, unplugging the tablet and plugging it back in but it always ends up doing this. Is this a driver issue? Cable issue? Bad tablet?

13 people have this problem
  • Hi Steven Lewis, there are several possible causes of your issue; the 3-in-1 cable, not enough power supplied to your tablet, your computer's USB port, your tablet's USB-C port, or your tablet's internal board itself. Kindly answer the following questions to have a better idea on what may have caused it:

    1. Does the tablet driver continue to show "Device connected" when the cycle of disconnecting and reconnecting is happening? 
    2. How about the screen; does it flash as well or is it just the tablet's LED light that is affected? 
    3. When you plugged your tablet back to your computer, have you tried plugging it to another USB port? 
    4. Have you tried connecting your tablet to another computer, if you have access to another unit? If you have, do you encounter the same issue?
    5. Is the red USB end of your 3-in-1 cable connected directly to a power outlet?


    Here's an article about the Kamvas 13 connection that may help: How do I connect the Huion Kamvas 13 to my computer?


    Best Regards,

    HUION Customer Support


  • I have the exact same issue (Windows 10, Kamvas 13, 3-in-1 cable). Please let me know if you find a solution.

    I have tried:
    Firmware and Driver update
    Different USB ports on motherboard
    Pugging in the red USB power (same result plugged in or not)
    Different USB ports on a PCI Express expansion card
    Changing Windows and BIOS USB power settings.

    I suspect some sort of driver (power/time out) issue.


    3 people like this
  • Hi Mike Chernett, thank you for sharing your issue with your Kamvas 13 connection. Since you've done some troubleshooting steps, it is possible that your cable may have caused your issue. 


    I see that you already have a ticket so kindly provide your tablet's serial number, purchase order number and a video of your issue in your ticket so we can further assist you. Thank you!


    Best regards,

    HUION Customer Support


    1 person likes this
  • Hi! I have the exact same problem with my Kamvas 13 2020 version. I'll go ahead and answer the questions as they pertain to me:




    1- The tablet driver shows the tablet disconnecting and reconnecting, not remaining connected



    2- The screen stays turned on, no flashing or anything




    3- Yes 




    4- No I only have one




    5- Yes it's connected to a phone charger: Input 100 - 240V-50/60Hz, 0,35A Output: 5V = 2A


    2 people like this
  • Have the same exact problem, keep disconnected & reconnect at random time. (sometimes its just once every few hours, sometimes its 2-5 times rapidly)


    display stay active when its disconnected, power led blink & driver icon turn grey. when its reconnected, the pen works fine & pressure still there.


    i have tried everything, uninstall & reinstall, use older driver version, disable usb power saving, delete wintab32, reinstall drive, disable device power saving, clean registry, wipe all ghost drives... anything that i can think of & find on internet and its still f happening.


    its definitely not cable problem too, because i have tried shaking it & wiggle the port but the disconnection is not triggered.


    2 people like this
  • I have replied to the troubleshooting steps in my ticket but I'll add the info here too for the reference of others with this issue:

    Have you plugged the red USB cable into a power supply

    Yes. An Amazon 5W AC Adapter Output 5.0V  1.0A


     

    1) Please make sure that the USB cable is connected securely, and the USB port is functional;
    Yes. All cables are secure (moving cables does not cause disconnect). The tablet functions normally apart from the disconnecting cycle.

    2) Change to a different USB port;
    I have tried multiple ports on the motherboard (ASUS Prime X570-PRO). I have also installed a separate PCI-E USB Card (Inatek 4 port PCI-E card) with its own drivers and tried the ports on that.


    3) Change to a different computer;

    I have not tried this yet, but I see from your support pages that others are having the same issues

    4) A video that can show the problem clearly;(upload to Dropbox or Google Drive would be preferred);
    Video of issue and showing red USB plugged into power supply:
    https://photos.app.goo.gl/QEnrRGygRYB57Bua7


    1 person likes this
  • I've replied to my ticket but I'm also adding the info below in case it's useful to others looking for a solution to this issue

    Have you plugged the red USB cable into a power supply

    Yes. An Amazon 5W AC Adapter Output 5.0V  1.0A


     

    1) Please make sure that the USB cable is connected securely, and the USB port is functional;
    Yes. All cables are secure (moving cables does not cause disconnect). The tablet functions normally apart from the disconnecting cycle.

    2) Change to a different USB port;
    I have tried multiple ports on the motherboard (ASUS Prime X570-PRO). I have also installed a separate PCI-E USB Card (Inatek 4 port PCI-E card) with its own drivers and tried the ports on that.


    3) Change to a different computer;

    I have not tried this yet, but I see from your support pages that others are having the same issues

    I've supplied a video to support, but I don't think the comments section here will allow links.

    BTW Ivandi, my issue is exactly the same: It keeps disconnecting & reconnect at random time. (sometimes its just once every few hours, sometimes its 2-5 times rapidly). I had to be ready with my phone to get a video as soon as I hear "the bings"


    1 person likes this
  • Here is a video of the issue
    https://youtu.be/LfyV1IcD7gg

  • Hi Chema Martinez,  Ivandi Van, and  Mike Chernett, the issue you are experiencing has been looked into. Since we would need detailed information from you such as your tablet's serial number, we will further assist you through your tickets. 


    Best Regards,

    HUION Customer Support

  • Hi Orliza, I'm having the exact same issue. Could you offer any assistance? Many thanks.


    1 person likes this
  • Same problem here, I think it's an issue from the model


    1 person likes this
  • Hi Zendon Page and Mauryopya, we will have to assist you further through email since we need to ask for detailed information. Kindly send the following information to service@huion.com:

    • Serial number (found at the back of your tablet)
    • Order number
    • Link where you purchased your tablet
    • A link to your video as you connect the cables to your tablet and computer and turning your tablet on. You can just use your phone in taking the video provided that we can clearly see your cable connections and your computer and tablet screens. Please send the video through WeTransfer or upload it to Dropbox or Google Drive. If you upload it, please make sure to remove the restrictions so anyone who has the link will be able to access it.
    • If you encounter an error message, please make sure to capture it in your video.


    Best Regards,

    HUION Customer Support


    1 person likes this
  • Hi, I have the same problem with my Kamvas 13 Should I send the information you ask for by mail? I bought it new a few days ago for "mercadolibre" and I have tried everything so that it does not continue to happen but it does not work

    1 person likes this
  • So... I got a response from Huion support. They want to send me a new 3-in-one cable BUT I have to pay £20 shipping (for the £35 cable) ...

    I asked why they think it's the cable that's the issue, but they just repeated that the cable is "broken".

    I'm not completely convinced the cable is the issue as the disconnects happen even when there is no movement of the cable or Kamvas 13. On top of that, it would be a coincidence that we ALL have "broken" cables that do the exact same thing.

    I also found this reddit post with more users with the same thing:
    https://www.reddit.com/r/huion/comments/jy2dxd/green_light_flickers_on_and_off_on_kamvas_13/

    Some suggest it could be a Driver/Win 10 problem (which seems more likely to me)

    So before paying to ship a new cable I'm testing my tablet on a different Win10 PC with a fresh install of the latest driver to see if that helps. So far 1 hour without disconnects, but I'll leave it on for a whole day and see if it does the same thing.


    1 person likes this
Login to post a comment