Huion KAMVAS pro 16 pen not working

Dear Huion team, My KAMVAS pro 16 pen is not working no matter what i do. I tried restarting the pen and redownloading the driver, but it still did not help. The monitoring calibration screen works, so I don't know why the pen doesn't work. Please help me :)

  • Hi TIMOTHY LUK, when you say that the monitoring calibration screen works, do you mean that the pen only works within the driver or do you mean that the driver is working fine and it's just the pen that is not working? 


    Kindly provide the following information so we can better assist you:

    1. Computer operating system you are using
    2. Driver version you installed
    3. Does the tablet driver show "Device connected"?
    4. Won't the pen work at all or just on certain software or programs?


    Please try to uninstall the driver, unplug your tablet and then plug it back in. Test if your pen works without the driver. If it won't, please send the following information to service@huion.com:

    • Serial number (found at the back of your tablet)
    • Purchase order number
    • Link where you purchased your tablet
    • A link to the video of your pen not working on the driver and your drawing programs. You can just use your phone in taking the video and send it through WeTransfer or you can upload it through Dropbox or Google Drive. If you upload it, please make sure to remove the restrictions so anyone who has the link will be able to view it.


    Best regards,

    HUION Customer Support

  • I’m also having a problem with my pen and tablet. It’s been acting strange now for a whole day and this isn’t the first time. I have a Kamvas Pro 16 and I use it with my Windows 10 laptop. When I use the pen on the tablet, the cursor appears as the shape of a diamond, and whenever I use my drawing problem the cursor lags for when I first touch the screen. I’ve tried disconnecting the tablet, but it still says my device is disconnected even though it seems to be working fine. I can’t even open up my Work Area and the programmed buttons on both the tablet and Pen aren’t working.
    MOV
    MOV
  • Hi Командир Ларсен, what driver version have you installed? Kindly try the following steps:

    1. Uninstall the current driver you have and unplug your tablet from your computer. Make sure you don't have any other tablet drivers installed on your computer, whether from us or other brands. Having multiple tablet drivers will cause issues on your tablet's performance.
    2. It is better to restart your computer after uninstalling the driver.
    3. Download the latest driver for your tablet from this link: Huion Kamvas Pro 16 Tablet Display Drivers
    4. While your tablet is not connected to your computer, install the driver and once done, plug your tablet back to your computer.
    5. Check whether the driver shows "Device connected" and when it does, check whether you are able to use your pen without any issues.
    6. Try doing the same procedure on a different computer and check if you still experience the same issue.


    Best Regards,

    HUION Customer Support

Login to post a comment