Tablet pen not working!!!


I have bought a H610 Pro (8192) tablet about 9 months ago. It worked well, had no issues at all. Then about 3 months ago, my pen wouldn't work, unless it was plugged to its charger. I didn't think much of it and just kept it plugged in its charger when I was using it. But yesterday evening, I was drawing, and I put my pen down. Earlier that month I had put the charger and pen together with tape, to keep them plugged. When I picked the pen up again, the tape fell off, and so did the charger, so I got it put back together, but when I used it, it wasn't working.

I tried everything, I uninstalled and reinstalled the drivers, updated them, checked the ports, everything! Nothing works. But the thing is, when I open the driver it says ''Device connected'', but when I use my pen, it doesn't work at all!! It doesn't matter if it's plugged in the charger or not. It doesn't work! It's like the pen is completely disabled. It doesn't show a red light when plugged in the charger. I changed the nibs as well, but it still didn't show any change from before.

Please help me with this, if possible. 

Thank you!

1 person has this problem
  • Hi ItzKiwii, based on what you've explained, I believe your pen is broken. I will create a ticket for you so we can see the status of your pen and send a pen replacement if you are still within the 1-year warranty. Otherwise, I suggest that you purchase a new pen.

    Best Regards,

    HUION Customer Support

  • Alright, thank you so much for responding.

  • You're welcome