Device Disconnected

Hi there

We brought a Huion GT220 V2 for my son for last Christmas and its 29th March and we have still not managed to get it set up correctly!

I have just brought a new computer as my previous laptop was very old and I thought that this might just be stopping me from setting up correctly - however, I still cannot get the Device Connected message and I just don't know what I am doing wrong???

Can anyone please help me!

With many thanks, Andria

2 people have this question
  • Hi Martin Begley, MD, thank you for sharing your experience and we appreciate your feedback on our instructions. We will review our installation instructions and update it accordingly. We're glad that your issue has been resolved as well.

    Please feel free to let us know what else we can do to further improve our products and services. Thank you!

    Best Regards,

    HUION Customer Support

  • I'm having the same problem with a h610 pro (purchased on 2016). I downloaded the driver (Driver_14.4.4.191025) but appear "device disconnected", I can use with drawing software but with no pressure. Then uninstalled the driver and installed this driver (Driver_12.0.4) Now the appear 'devise connected" but the pen doesn't work. Why this is happening?

    Additional details:

    ✭ I have a Mac with Catalina

    ✭ S/N H610PRO151210983

  • Hi,

    I'm having the same problem with a H610 PRO (purchased on 2016).  I downloaded the driver ( but appears "devise disconnected", but when I use the drawing software, the pen works with no pressure (I rebooted the computer after installation). Then proceeded to uninstall the driver and installed this driver (12.0.4) Now appears "device connected" but the pen doesn't work. Why this is happening? Which is the correct driver?

    Additional details

    ✭ I have a Mac with Catalina OS

    ✭ S/N H610PRO15121983

  • Hi Elena Zarza, the reason why the 14.4.4 driver version shows "Device disconnected" is because this is the wrong driver version for your tablet. Based on your serial number, your tablet model is the H610PRO(2048), thus, the Driver_12.0.4 version is the one compatible to your tablet.

    Please go to Mac System Preferences > Security & Privacy > Privacy > Accessibility and make sure that you add HuionTablet and TabletConsole apps on your whitelist. Usually, this is the main cause why the driver recognizes the tablet but the pen won't work. When the necessary apps are added on the whitelist, the pen issue will then be resolved. Restarting the computer or uninstalling and reinstalling all over again will also help if you are unable to get the pen to work after doing all these steps the first time. 

    NOTE: Do not just drag the Huion Tablet driver app to your trash to uninstall it. This is not the proper way. You need to find the Huion Tablet folder and click on the uninstall program to properly uninstall the driver. Improper uninstallation will cause issues as well.

    Best Regards,

    HUION Customer Support

  • Hello, I bought a huion kamvas 16 tablet and I use a macbook pro with mac os 10.13.3 High Sierra (usb c connections). I download the last driver but "device disconnected". i went also to Mac System Preferences > Security & Privacy > Privacy > Accessibility and it stills disconnected. how to connect it? 

    (603 KB)
  • Hi  Fabrice Papahn,  please try the steps below that may help resolve your issue: 

    1)Please make sure that the USB cable is connected securely, and the USB port is functional;

    2)Change to another USB port;

    3)Change to a different computer;

    4)Re-install the latest driver 

    Please uninstall the driver you are using now, unplug the tablet, and close all the drawing programs and anti-virus software before installing the new driver. Then re-plug the tablet in.

    Here's a step by step instructions on how to reinstall the driver:
    * Log out from the Huion driver, close all drawing programs you are running, and close your anti-virus software.
    * Uninstall the Huion driver from the Control Panel.
    * Unplug the USB cable.
    * Download the latest driver from the Huion website.
    * Reboot your computer.
    * Plug the tablet back in.

    Moreover, please reply to us in the ticket and provide the product information so we can help resolve your issue.

    Best regards, 

    HUION Customer Support

  • The solution was the port. Each port must to be independant (hdmi to usb c, usb to usb c).

    Important :  a big hub with usb, hdmi, usbc,... doesn't work at all!

    I tried with an old version with a macpro from 2011 : Mac 10.11.6 (El capitan) and it's working!

    So, it is not a question with virus or version on mac, only with port.

  • Hi  Fabrice Papahn, Thank you for getting back to us. We are very glad to hear the problem is solved.

    That is correct; you cannot plug both the HDMI and USB-A to 1 USB-C port. They must be separate. Anytime you encounter a problem with our products, please feel free to contact us. We will do our best to help you.

    Hoping you have a great day and enjoy your tablet!

    Best regards, 

    HUION Customer Support

  • Hi,

    I have a H640P and I've been using it for quite some time now.
    Earlier, I planned to install a Firmware update so that i can use it with my phone whenever i feel like it.

    After i installed the program, a text popped up telling me if i should install some kind of driver, i think its was the gd32 driver,  i said yes. It was going well, until the part in the installation where i need to plug out and plug in the cable. It said that i need to pull out the end where its connected to the tablet itself, but i pulled out the wrong end, the one in my usb port.. after that I quickly plugged it back in but as soon as i did the tablet wasn't working anymore. I thought it was the driver so i reinstalled them but it didn't work. the drivers weren't recognizing the tablet itself.

    I noticed that the light that supposed to light up when its connected in the tablet, its not there anymore. i did some research and maybe the drivers weren't the problem but the hardware of the tablet. i really don't have the money to buy a new one so i was hoping somebody can lend me a hand on this one.

  • Hi Arsene, please try to run the firmware update again and take a video as you do so. Let me know if it still won't go through and share your video so we can see what happens. Looking forward to your reply.

    Best Regards,

    HUION Customer

    1 person likes this
  • I was able to take the video but couldn't upload it here since it has exceeded the attachment size.

    so i uploaded the video here,

  • Hi Arsene, thank you for the video. Kindly try this firmware specific for H640P and follow the attached instructions. 

    Best Regards,

    HUION Customer Support

  • I followed the instructions given to me, but when Im about to start the programming, it shows me an error saying " Update APROM failed ".

  • Hi Arsene, it is unfortunate that you still encountered an error. I will create a ticket for you so we can further look into your issue.

    Best Regards,

    HUION Customer Support

  • device disconnected but  led light is on in huion 640 p i have tried all methods still no use please help me

Login or Signup to post a comment